Subject: Swap Space on Unix

From: Benjamin Joesph Moritz <[email-masked]>
Date: Wed, 02 Feb 2000 11:01:42 -0700

Dear CCLers,

	I'm having a problem running more than two MP2 jobs on our system computer
with G98.  We are using a Digital Unix system with a 533 MHz DEC Alpha.  We
have 512 MB of physical memory and are using a 1 GB swap (disk) space.  My
question is, are there any problems with increasing the swap space to say
3-6 GB?  When more than two MP2 jobs are running an error message appears
saying "out of swap space."  Thanks in advance!

Ben Moritz
Boise State University
1909 Tendoy Dr.
Boise, Id
	83705
[email-masked]
ph. # 208-433-1579

---

From: Peter Shenkin <[email-masked]>
Date: Wed, 2 Feb 2000 15:59:26 -0500 (EST)

Hi,

Well, if the jobs are really swapping then you will probably
be greatly slowed down by this strategy, but it ought to be
harmless from a system point of view.

There is also a way to configure DECs to "overcommit" virtual
memory.  This allows programs which allocate large dataspaces
to run, just as long as they don't use all the space they
allocate.  That is, as long as the part they use fits in
memory, the job can run.  

I don't know whether G98 is careful never to allocate more 
memory than it needs, but if it sometimes does allocate 
more than it actually uses, configuring your OS this way 
would be another way to go.

BTW, your Subject: refers to a UNIX question, but in fact
the answer differs for different flavors of UNIX.  The above
is correct for TRU64, AFAIK.  

Hope this helps,

	-P

On Wed, 2 Feb 2000, Benjamin Joesph Moritz wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 

--
** Whether the playing field is level depends on the coordinate system. ***
********* Peter S. Shenkin; Schrodinger, Inc.; (201)433-2014 x111 *********
*********** [email-masked]; http://www.schrodinger.com ***********