Subject: Re: CCL:Batch jobs of G98

From: "Tapas Kar" <[email-masked]>
Date: Thu, 9 Mar 2000 09:21:04 -0600

In Aix, add following lines in the /etc/qconfig file

rung98:
        s_statfilter = /usr/lpd/aixshort
        device = gq1,gq2
        up = TRUE
gq1:
        file = FALSE
        backend = /bin/csh
gq2:
        file = FALSE
        backend = /bin/csh

r-g98:
        device = gq-s
        up = TRUE
gq-s:
        file = FALSE
        backend = /bin/csh

After adding those lines, check the queue by using " qchk -A"

3% Tapas/Risky4> qchk -A
Queue   Dev   Status    Job Files              User         PP %   Blks  Cp
Rnk
------- ----- --------- --- ------------------ ---------- ---- -- ----- --- 
---
rung92  gq1   RUNNING   104 /USERS_HOME/tapas/ tapas         0  0     1   1
1
rung92  gq2   RUNNING   105 /USERS_HOME/tapas/ tapas         0  0     1   1
2
r-g92   gq-s  READY

Now use the following script to submit GXX jobs,

thisdir=`pwd`
echo  /app/g98A7/g98/g98 $thisdir/$1 > $1.exe
qprt -Prung92 $thisdir/$1.exe  ( submit jobs in any available queue)
#qprt -Prung92:gq1 $thisdir/$1.exe (submit jobs in gq1 only)
#qprt -Prung92:gq2 $thisdir/$1.exe  ( submit jobs in gq2 only)
#qprt -Pr-g92 $thisdir/$1.exe  (submit jobs in gq-s only)
echo Job $1.com submitted
qchk -A | grep -v "lp" | grep -v "bsh"

** don't put the comments within bracket in the script, it is just to
explain you)
I used a file named "subj" which contains the ablve lines, and then changed
the mod to all executable
using
chmod +x subj
Then, use the following command
./subj  GXX-input-file-name  (.com is nor required)
you will see one line GXX-input-file-name.exe files for each job, delete
those after job completion.

Hope this will work.

****************************************************************************
***
Is any one out there using similar setup for other operating systems, please
post it to CCL************.
****************************************************************************
***
Tapas

----------------------------------------------------
Tapas Kar
Department of Chemistry
1245 Lincoln Dr. # 146F
Southern Illinois University
Carbondale, IL 62901-4409

Tel: 618-453-6485(Off)/6433(Lab)
Fax: 618-453-6408

email: [email-masked]
            [email-masked]
----- Original Message -----
From: Yubo Fan <[email-masked]>
To: Tapas Kar <[email-masked]>
Sent: Wednesday, March 08, 2000 10:48 PM
Subject: Re: CCL:Batch jobs of G98

> RedHat Linux 6.1 and AIX 4.2
>
> Tapas Kar wrote:
>
> > What operating system you are using?
> > ----------------------------------------------------
> > Tapas Kar
> > Department of Chemistry
> > 1245 Lincoln Dr. # 146F
> > Southern Illinois University
> > Carbondale, IL 62901-4409
> >
> > Tel: 618-453-6485(Off)/6433(Lab)
> > Fax: 618-453-6408
> >
> > email: [email-masked]
> >             [email-masked]
> > ----- Original Message -----
> > From: Yubo Fan <[email-masked]>
> > To: <[email-masked]>
> > Sent: Tuesday, March 07, 2000 9:39 PM
> > Subject: CCL:Batch jobs of G98
> >
> > > Hi, everyone,
> > >
> > > I have many G98 jobs to run on unix systems one by one. I don't
> > > understand how to edit a batch file and run it for the explanation in
> > > the manual are so simple. Could someone help me?
> > >
> > > Thanks in advance
> > >
> > > Y. Fan
> > >
> > > --
> > > =============================================================
> > > Yubo Fan                         Email: [email-masked]
> > > Organic Synthesis Lab
> > > The Department of Chemistry
> > > Fudan University                 Phone: 8621-65648139
> > > No. 220 Handan Road              Fax:   8621-65641740
> > > Shanghai, 200433
> > > P. R. China
> > > =============================================================
> > >
> > >
> > >
> > >
> > >
> > > -= This is automatically added to each message by mailing script =-
> > > [email-masked] -- To Everybody    |   [email-masked] --
To
> > Admins
> > > [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> > > [email-masked] -- archive search    |    Gopher:
gopher.ccl.net
> > 70
> > > Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
> > [email-masked]
> > >
> > >
> > >
> > >
> > >
>
> --
> =============================================================
> Yubo Fan                         Email: [email-masked]
> Organic Synthesis Lab
> The Department of Chemistry
> Fudan University                 Phone: 8621-65648139
> No. 220 Handan Road              Fax:   8621-65641740
> Shanghai, 200433
> P. R. China
> =============================================================
>
>
>

---

From: Brian Salter-Duke <[email-masked]>
Date: Sat, 11 Mar 2000 13:53:58 +0930

>         s_statfilter = /usr/lpd/aixshort

I prefer to use a generic batch queue such as:-
 
bat_ksh:
	device = bat_kqd
        discipline = fcfs
bat_kqd:
        file = FALSE
        backend = /bin/ksh 

This one happens to be the Korn shell as my G98 stuff is configured for
that shell, but I also have a C-shell entry.

> Queue   Dev   Status    Job Files              User         PP %   Blks  Cp

This is a modification that does it better:-
 
thisdir=`pwd`
cat <<END > $1.job
#!/bin/ksh
cd $thisdir
rm -f core
rm $GAUSS_SCRDIR/gau*
. $g98root/g98/bsd/g98.profile
$g98root/g98/g98 $1 
END
qprt -Pbat_ksh $thisdir/$1.job  
echo Job $1.com submitted
qchk -A | grep -v "lp" | grep -v "bsh"
rm -f *.job

It clears the *.job file and also removes core files and scratch files from
a previous run. Note I set $g98root in my .profile but call g98.profile at run 
time.

> those after job completion.

We are talking about a very AIX-specific solution to the problem here.

I run NQS on all my machines, including AIX, but the qconfig solution for
AIX is probably the simplest solution.

Cheers, Brian.

-- 
        Associate Professor Brian Salter-Duke (Brian Duke)
Chemistry, Faculty of Science, IT and Education, Northern Territory University,
          Darwin, NT 0909, Australia.  Phone (61) (0)8-89466702
e-mail: [email-masked]  or [email-masked]