Subject: >2 GByte patch for ext2 (fwd)

From: <[email-masked]>
Date: Mon, 13 Mar 100 21:44:05 +0300 (MSK)

From: Mikhail Kuzminsky <[email-masked]>
To: [email-masked]

According to Eugene Leitl
> From [email-masked] Fri Mar 10 04:49:08 2000
> From: Eugene Leitl <[email-masked]>
> Date: Thu, 9 Mar 2000 14:14:23 -0800 (PST)
> To: <[email-masked]>
> Subject: >2 GByte patch for ext2 
> Sender: [email-masked]
> 
> Sorry for such a banal question, but I've tried to find the ext2 patch
> which allows >2 GByte files, so far in vain. (It is a big problem in
> computational chemistry with QM packages like Gaussian and GAMESS). I
> thought there was a search engine for the Beowulf list, but I wasn't
> able to find it, either (it isn't linked from the Beowulf site?).
> 
   I think that ext2 patch isn't enough for work w/large files
"from" G98 or GAMESS. The reason is that you need to use in the
program the new system calls suppoted by patch instead of usual.
But in the case of GAMESS you have Fortran I/O which runtime library
don't use new system calls. In the case of G98 you will need
to change NTRAN routines source to use new system calls.

   I may be wrong because I'm not using this patch really
(the reason is practically - that I said above), but I'll
be happy if I'm incorrect :-) !

PS. May be you may try to split files in G98 (%RWF etc) between
different filesystems ?

Mikhail Kuzminsky
Zelinsky Institute of Organic Chemistrty
Moscow
-------------------------------------------------------------------
To unsubscribe send a message body containing "unsubscribe"
to [email-masked]

---

From: [email-masked]
Date: Tue, 14 Mar 2000 11:47:41 +0300

The PC GAMESS v. 5.5 (and newer) is capable to support large 
files on ext2 volumes via transparent  splitting of large files.

Best regards,
Alex Granovsky

>But in the case of GAMESS you have Fortran I/O which runtime library don't use
>new system calls. In the case of G98 you will need