Subject: Re: CCL:Is CML dead?

From: "Rzepa, Henry" <[email-masked]>
Date: Tue, 11 Apr 2000 16:03:12 +0100

We have mounted a number of  XML tests using  CML on

http://www.xml-cml.org/test/

(a mirror site if the above is slow is  http://www.ch.ic.ac.uk/chimeral/test/ )

You will need Internet  Explorer  5.0 or 5.5 for Windows.
This has to be Java enabled in the Security settings.
Internet Explorer 5.0 for  MacOS SHOULD work, but fails.
We are currently in contact with Microsoft to help resolve
this problem (if you are using MacOS, then 
http://www.ch.ic.ac.uk/chimeral/test/mactest1.xml DOES work!.
Tests 2-5 do not!) 

What the browser should then do  is the following

1. A request for an XML Schema defining CML is made. 
2. An XML document is retrieved and validated against the  CML schema
3. If valid, an XSL stylesheet is retrieved and applied
4. This produces display  HTML which in turn invokes the tools needed
to display the content.
5. We have developed a range of XSL stylesheets to make use of various
Java software available, some  OpenSource (JMol, JSpec, etc) some not (JME,
Marvin, etc). 

We also have a server-side implementation which needs some debugging
(ie the XSL transforms are done server side rather than browser side).
Shortly, we will offer a server-side CML validation service against the schema noted
above

We in particular seek 

a) Information about freely available Java programs to incorporate into  our 
demos (these can be seen at http://www.ch.ic.ac.uk/chimeral/ )
b) Contributions to the OpenSource Stylesheet library
c) Any other similar demos others might have come up with.

A Markup Languages workshop, including XML and CML, will be held
at  Chemint2000 (www.chemint.org) this September, and  if you wish to
participate, do please come along! 

There was an interesting debate about  Graphical user interfaces for
Chemistry on this list a few months back.  I note with interest the development
by Netscape (Netscape 6 does not yet support  XSL, and so does not run the 
above demos) of XUL (eXtensible  User-interface Language).  One presumes
that libraries of  XUL might develop in a manner we anticipate  XSL libraries
developing.

Finally,  I note XML-Signature Syntax and Processing", http://www.w3.org/TR/xmldsig-core/ 
which will allow digital signatures to be added to  XML/XSL documents
(see J. Chem. Inf. Comp. Sci., 1999, 39, 483-490. )
-- 

Henry Rzepa. +44 (0)20 7594 5774 (Office) +44 (0)20 7594 5804 (Fax)
Dept. Chemistry, Imperial College, London, SW7  2AY, UK. 
http://www.ch.ic.ac.uk/rzepa/

---

From: David van der Spoel <[email-masked]>
Date: Sat, 8 Jul 2000 23:02:25 +0200 (CEST)

On Tue, 11 Apr 2000, Rzepa, Henry wrote:

>http://www.xml-cml.org/test/ (a mirror site if the above is slow is
>http://www.ch.ic.ac.uk/chimeral/test/ ) You will need Internet
>Explorer 5.0 or 5.5 for Windows.  

I think this is close to the heart of the problem. The current efforts
are directed to *new* tools for visualisation (I work in a
Windows-Free (tm) environment) while we have plenty of old tools which
do the job, but are just not CML/XML enabled. 

In the tests there are examples of combined structure/spectra
files. Instead of dumping the CML in a slow browser I would like to
give the CML file to rasmol to view the structure and the same file to
e.g. xmgrace to see a spectrum. What is needed for that is a simple
comprehensive C-library which can be called by the respective
programs. I realize that there is a need for (web) publishing tools,
and that the current java tools are a means to this end, however
without programs that generate CML there is nothing to publish.
I am willing to contribute to the library, as long as someone else (Henry?)
keeps the overview and coordinates things, which as Christoph Steinbeck
pointed out is crucial.

Groeten, David.
________________________________________________________________________
Dr. David van der Spoel		Biomedical center, Dept. of Biochemistry
s-mail:	Husargatan 3, Box 576,  75123 Uppsala, Sweden
e-mail: [email-masked]	www: http://zorn.bmc.uu.se/~spoel
phone:	46 18 471 4205		fax: 46 18 511 755
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

---

From: Peter Shenkin <[email-masked]>
Date: Tue, 11 Apr 2000 20:08:03 -0400 (EDT)

Hear, hear.

It was a lack of such tools several years ago that caused us to
shy away from XML/CML when designing our new Maestro interface.

It is disappointing if, indeed, there are no such tools linkable
to C, Fortran and C++ even today.

Henry, what sayest thou?

	-P.

On Sat, 8 Jul 2000, David van der Spoel wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 

--
** Whether the playing field is level depends on the coordinate system. ***
********* Peter S. Shenkin; Schrodinger, Inc.; (201)433-2014 x111 *********
*********** [email-masked]; http://www.schrodinger.com ***********