Subject: The disk constrain in Gaussian98?

From: "Chungen Liu" <[email-masked]>
Date: Thu, 8 Jun 2000 06:27:38 +0800

Dear cclers:

I am confused by the following problem i encountered during a G3 computation using G98.

Discription of the computor:

     CPU  PII 350/256M/6.4G+20G
     Linux 6.1
     Gaussan98 A.7
   
The input file is 
%mem=20000000
%chk=c6h6
#p g3 maxdisk=5gb  geom=check

test

0,1
c
c 1 r1
c 2 r1 1 120.0
c 3 r1 2 120.0 1 0.0
c 4 r1 3 120.0 2 0.0
c 5 r1 4 120.0 3 0.0
h 1 r2 2 120.0 3 180.0
h 2 r2 3 120.0 4 180.0
h 3 r2 4 120.0 5 180.0
h 4 r2 5 120.0 6 180.0
h 5 r2 6 120.0 1 180.0
h 6 r2 1 120.0 2 180.0

r1=1.4
r2=1.0

The computation stop near the end of step 7. the error message looks like:

> Leave Link  801 at Wed Jun  7 09:45:00 2000, MaxMem=   20000000 cpu:       0.1
>(Enter /home/gauss98/g98/l906.exe)
> FulOut=F Deriv=F AODrv=F
>   MMem=           7  MDisk=          21 MDiskD=          21
>  W3Min=     2119320 MinDsk=     2845658 NBas6D=         348
> NBas2D=       61464    NTT=       60726 LenExt=    17878965
>    MDV=    19878965 MDiskM=         256 NBas2p=       16956
> Disk-based method using OVN memory for 21 occupieds at a time.
> Estimated scratch disk usage=   276034065 words.
> IMap=  1  2  3  4  5  6  7  8  9 10 11 12 13 14 15 16 17 18 19 20
> IMap= 21
> Actual    scratch disk usage=   275659983 words.
>Erroneous write during file extend. write 159743 instead of 4096
>Probably out of disk space.

The scratched rwf file is only about 2148M, which is far less than the size of the partition.

Any one can help me to solve this problem?

Best regards

---

From: WeiQuan Tian <[email-masked]>
Date: Thu, 8 Jun 2000 09:52:59 -0400 (EDT)

Mr. Liu:

  The largest rwf file size is about 2.1GB, so you might want to split
the rwf file into several ones.

 Hope useful.

 Wei Quan Tian

On Thu, 8 Jun 2000, Chungen Liu wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
>

---

From: Alexander Wittkopp <[email-masked]>
Date: Thu, 8 Jun 2000 18:04:48 +0200 (MET DST)

> the rwf file into several ones.

   This is only true for 32 bit systems, lihe Linux etc. More
sophisticated 64 bit OS allow much bigger files like True64 (16 TB!),
Solaris (1 TB).  Gaussian seems to be able to handle huge rwf. We ran jobs
with rw files of about 8GB.

Cheers,
                              Alexander
 
*******************************************************************************
                                              ("`-/")_.-'"``-._
Alexander Wittkopp                            (. . `) -._    )-;-,_()
Institut fuer Organische Chemie               (v_,)'  _  )`-.\  ``-
Georg-August Universitaet                     _;- _,-_/ / ((,'
Tammannstrasse 2                            ((,.-'  ((,/
37077 Goettingen   Email: [email-masked]   URL: http://www.gwdg.de/~awittko   
Germany            Phone: +49-(0)551-393290 Fax: +49-(0)551-399475

"eine ungerade Zahl, am besten prim hat immer guenstige Auswirkungen auf 
                     cache-trashing."
                                            T. Nau 
*******************************************************************************

---

From: WeiQuan Tian <[email-masked]>
Date: Thu, 8 Jun 2000 13:22:32 -0400 (EDT)

Right, I even had 14GB rwf files in 64 bit computer. For  Gaussian
it might be able to use up to 16GB rwf file for 64 bit OS.

 Wei Quan

---

From: Jochen Buehler <[email-masked]>
Date: Thu, 8 Jun 2000 19:18:38 +0200 (CEST)

> with rw files of about 8GB.

No. It is sometimes true for 32bit OSes but with Linux 2.4 on ia32
(and compatible architectures) you already get files within the
terabyte range, as is possible on Linux/Alpha and Linux/Sparc64
since a long time.

      Best Regards,

         Jochen

Jochen Buehler, Dipl.-Chem      EMail:  [email-masked]
AG Prof. Dr. Daltrozzo                 [email-masked]
Fachbereich Chemie              Phone: +49-7531-882094
Universitaet Konstanz           Fax:   +49-7531-883043
78457 Konstanz, Germany         Private EMail: [email-masked]

---

From: David Konerding <[email-masked]>
Date: Thu, 08 Jun 2000 10:23:27 -0700

>with rw files of about 8GB.

A clarification-

32 bit systems can use 64 bit pointers for file structures.  There are patches
to the linux kernel and c library to do this, and I think Red Hat 6.2
includes these by default.

Furthermore, Linux isn't just a 32 bit OS.  On the Alpha or any other 64 bit
platform Linux is a full 64 bit OS.

So you can't claim it's a matter of sophistication, only a matter of
standard implemented features.

Dave

---

From: Jochen Kuepper <[email-masked]>
Date: Thu, 8 Jun 2000 16:27:13 +0200 (CEST)

> the rwf file into several ones.

Well, that's actually a ext2 filesystem limitation on 32 bit
machines. IIRC there was a discussion on the Linux large-fiel patches
on this list; for sure you'll find it in the linux-kernel list
archives.
I don't know the current status, but I gues it is stable by now.

Jochen
-- 
Heinrich-Heine-Universität, Institut für Physikalische Chemie I
Universitätsstr. 1, Geb. 26.43 Raum 02.29
40225 Düsseldorf, Germany                phone ++49-211-8113681
http://www.Jochen-Kuepper.de               fax ++49-211-8115195

---

From: "eugene.leitl" <[email-masked]>
Date: Wed, 7 Jun 2000 22:31:22 -0700 (PDT)

> The scratched rwf file is only about 2148M, which is far less than the size of the partition.

You've ran into Linux ext2 file system 2 GByte file limit. You'll need to
upgrade to a bleeding edge kernel (2.4 candidate has just been released),
and recompile Gaussian with 64 bit file system support. ReiserFS and XFS
(SGI's journalling file system) might be another thing to look for.
 
I also recommend looking at searchable Beowulf list archives at
http://supercomputer.org/

---

From: "Li Zhenhua" <[email-masked]>
Date: Thu, 8 Jun 2000 22:36:21 +0800

Dear Chungen,
Mr Tian suggested split the rwf file. I have met the same problem in
HP-UNIX, this method seems can't help. No matter how many parts I split, the
program will full each part untill it full all the available disk space. It
seems this is related to the oporating system. In the past, Win95 can't
manage continuous disk space more than 2 Gb. Seems this is the same problem,
the system just cannot manage a continuous file more than 2 Gb.So the file
system of Linux, as well as HP-UNIX is not true 32 byte.

I remember someone had discussed this problem in CCL at the end of last
year.

----- Original Message -----
From: "Chungen Liu" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, June 08, 2000 6:27 AM
Subject: CCL:The disk constrain in Gaussian98?

> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
[email-masked]

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com