Subject: Problem with stability of linux

From: "Krzysztof Radacki" <[email-masked]>
Date: Mon, 3 Jul 2000 19:08:51 +0200

Hi,
I got some problems with the linux-box on which I work.
Real often the maschine hang during gaussian calculations
in SMP-modus with following message (just example):
====
Unable to handle kernel NULL pointer dereference at virtual adress
00000018
current -> tss.cr3 = 0e0a6000, %cr3 = 0e0a6000
*pde = 00000000
Oops = 0000
CPU = 1
EIP = 0010: [<c0111478>]
EFLAGS: 00010207
ax: a7553000 ebx: daad4000 ecx: 00000000 edx: c023c000
esi: 00000000 edi: 00000000 edp: daad5fbe esp: daad5f9c
de: 0018  ec: 0018  sw: 0019
Process l502.exe (pid:727, process nr:7, stackpage: daad5f9c
Stack: 00000000....... some lines
CallTrace : [<c0...>]
Code: 8b 41 18 c1 f8 d1 03 41 1c 89 41 18
8b 49 34 81 f9 00 c0 23
======
The questions: why  and what should I do again   :)
Is it problem of software (I've change the kernel and I can't see any =
difference),
is it SMP-hardware or maybe memory? How can I test it?

regards
Krzys Radacki

---

From: Alain Borel <[email-masked]>
Date: Tue, 04 Jul 2000 17:43:54 +0200 (MET DST)

> in SMP-modus with following message (just example):

< sad example of stack trace dump deleted>

> Is it problem of software (I've change the kernel and I can't see any
> difference),

What kernel version are you running? I can assure you that some versions
are _rock_solid_! My best uptime so far has been 419 days (unfortunately
a hardware upgrade forced me to shutdown...)
However I must admit that I don't have to much experience with SMP under
Linux.

If you want to test your memory, you might want to check memtest86 (assuming
you're using Linux on an Intel-compatible system, of course):
http://reality.sgi.com/cbrady_denver/memtest86/

----------------------------------
Alain Borel <[email-masked]>     Year 2000: not the 21st century
Date: 04-Jul-00 Time: 17:37:55

---

From: Jochen Kuepper <[email-masked]>
Date: Tue, 4 Jul 2000 18:00:03 +0200 (CEST)

> is it SMP-hardware or maybe memory? How can I test it?

Looks like a kernel problem (due to hardware failure or not). Do some
oops-tracing (look in your kernel sources for documentation) and ask
on linux mls or newsgroups.

Jochen
-- 
Heinrich-Heine-Universität, Institut für Physikalische Chemie I
Universitätsstr. 1, Geb. 26.43 Raum 02.29
40225 Düsseldorf, Germany                phone ++49-211-8113681
http://www.Jochen-Kuepper.de               fax ++49-211-8115195