Subject: Summary: Creating a movie of a moving molecule

From: "Darren Fayne" <[email-masked]>
Date: Fri, 21 Jul 2000 06:29:31 -0700

Hi cclers,
    I have just noticed Damian Scherlis' question and it occurred to me that I had never posted a summary of an enquiry I had sometime back. Apologies to anyone who was eagerly awaiting it (particularily Anita)!!!

My initial question

  Hi all,
    I've a quick question for you guys. I am wondering how to create a movie of   a molecule that I have rotated and moved for inclusion in a PowerPoint presentation?
    Preferably freeware that runs under Windows 95, but I also have access to IRIX 6.3.
    Any personal experience on what you consider to be the best software would be much appreciated.
    Thanks in advance,
  Darren Fayne

Unfortunately I did not have much time to delve into all the different options available but what worked well for me was screen capturing the image of my molecule as I slowly rotated/moved it. Paintshop Pro converted the rgbs to jpgs. Then the Paint Shop Pro 6 animation shop was used to piece the images together and create an avi.

--------------------------------------------------------------------------------------------------

Here is the replies that I received for which I am very grateful. I'm sure they will be of interest to many people as a major hurdle in getting your scientific infomation across is actually catching the audience's attention and showing them the 3D aspects of your molecule/reaction!

Short term solution (as you want freeware!), this is what I did (not saying 
it's the best way ...)

Get WebLab (www.msi.com) import individual frames, size / render them and 
export as jpegs, then render them into a movie with animation software (I 
used JASC Animation Shop for a quick fix).  Nice results, but doesn't 
really help for long-term solutions as a freeware solution.

Other things I've tried are MolMol (www.bio.ethz.ch ??) vmd 
(www.ks.uiuc.edu) and gOpenMol (www.csc.fi/~laaksonen ??) to get fairly 
nice renderings, but WebLab gives the nicest result (for my needs, anyway).

I also put PoVRay between WebLab and the movie renderer to get *even nicer* 
results.

I have been working in an art college (not doing 'molecular art' or other 
such cliched things(!)) and it's not really *that* much easier making a 
movie with the 'proper' software (Premiere, etc) than it is to do 'in your 
bedroom' as it were.

If you need a hand, let me know if I can help!

Simon Hogg
-------------------------------------------------------------------------------------------------

ON a sgi it's easy.

1.) generate the configs you want to animate and save in a PDB file
2.) use Rasmol (freeware) to image the configs, write a rasmol script to do
any rotations, shading, etc...that you want  and generate a gif image.
this you have to do by hand for one of the files to get the image to look
the way you want it to look. I have a shell script which does this as a
batch job  once I get it set on the first config. The key is to use rasmol
to generate gif images.  What you wind up with is a set of gif images
of the system at various time frames.
3.) then use moviemaker (on the SGI) to string together the gif images
and save as a quicktime movie.
4.) power-point away

I've also used Mathematica to generate movies....which is easy as well.

Eric R Bittner, Asst. Professor                            ph: 713-743-2775
Dept. of Chemistry 
fax:713-743-2709
University of Houston, Houston TX  77204
email: [email-masked]   http://eiger.chem.uh.edu/bittner/index.html
-------------------------------------------------------------------------------------------------

Darren,

I've got a collection of movies that I created with a combination of
RasMol, Molscript, Raster3D and perl script,

    http://www.bmm.icnet.uk/people/turcotte/resources/

Marcel Turcotte                          Biomolecular Modelling 
Laboratory
[email-masked]                 Imperial Cancer Research Fund
Phone/Fax +[44]-(020)-7269-3348/3258     PO Box 123, 44 Lincoln's 
Inn Fields
http://www.bmm.icnet.uk/people/turcotte  London WC2A 3PX, England
-------------------------------------------------------------------------------------------------

Dear Darren,

you can include molecules built with WebLab Viewer in your presentation.
You can even start it from your ppt presentation and rotate etc. the molecule
while giving the presentation. A light version of the WebLab Viewer is
downloadable for free at http://www.msi.com
Best regards
Klaus

Klaus Stark,PhD
Application Scientist
Molecular Simulations Inc.
Inselkammerstr. 1
82 008 Unterhaching-Muenchen
Germany

Phone : 0049-89-61459-420
Mobile : 0049-172-936-3380
Fax : 0049-89-61459-400
E-Mail : [email-masked]
Web Page : http://www.msi.com
-------------------------------------------------------------------------------------------------

Dear Darren,
I have spent some time around this subject.
Finally the best way (for me) is the use of both WeblabViewer pro
(available on the MSI web site) and Paint shop pro 6.
They are not freeware but you can try the demo versions.

With Weblab, you can transform automaticaly many coordinate files (in various
format) in hight quality pictures by using the integrated script language.
I can send you a exemple of a script.
The second step is performed with the animation module of paint shop
which allows to create a movie provided that AVI is the saving format.
Microsoft AVI file seems to be the best for a Powepoint presentation.

In my case, a full screen hight quality movie with 130 frames takes
10 Mo and runs fine on my notebook.
Hope this help.
Eric Vangrevelinghe, PhD.
-------------------------------------------------------------------------------------------------

Dear Darren:
     I am not sure of how this would be done, and so I would be interested
if you could post a summary of the answers received -- when such a summary
becomes available.
    Recently, I have had to produce two animations for a Web page using
animated gifs and/or Macromedia flash.  It works well on the Web page, but
I have not tried importing these into Powerpoint.  Seeing if Powerpoint
could handle these types of files would be something that I would first
check out.
Best wishes on a speedy solution,
Anita Zvaigzne
-------------------------------------------------------------------------------------------------

I use GIMP to make animated GIFs. I think there is a version of GIMP
for Windows, and I hope that PowerPoint knows about animated GIFs,
but I have zero experience with Windows.
-------------------------------------------------------------------------------
Konrad Hinsen                            | E-Mail: [email-masked]
Centre de Biophysique Moleculaire (CNRS) | Tel.: +33-2.38.25.55.69
Rue Charles Sadron                       | Fax:  +33-2.38.63.15.17
45071 Orleans Cedex 2                    | Deutsch/Esperanto/English/
France                                   | Nederlands/Francais
-------------------------------------------------------------------------------

Hi Darren
One, laborious, way could be the following:
Draw the molecule in successive stages of rotation, saving each time as a *.gif.
Then import into Powerpoint and use the animation feature to create the movie.
This works OK for Cerius2, hwoever that's not freeware :-(
Try IsisDraw maybe (www.mdli.com) or do a search..
Micko

Mr. Michael Nolan BSc. MEngSc.    Aldo's SuperWhiteArmy
NMRC (Ireland's ICT Research Center),  
Lee Maltings, Prospect Row, Cork, IRELAND 

mail: [email-masked]; 
http://www.nmrc.ie; http://trfc.editthispage.com
Tel:   + 353 21 4904113; Fax: +353 21 4270271
-------------------------------------------------------------------------------------------------

Hi Darren,

                The best thing is to convert it to a .mpeg file and embed that into

                you powerpoint presentation. As long as the .mpeg file is in the
                same directory you can run the movie within the presentation.

                There are quite a few .mpeg players and file converters available.
                The standard SGI mediatools (movieconvert and mediaplayer
                are good enough to create .mpeg files).
                Hope this helps,
                Shyam
-------------------------------------------------------------------------------------------------

Hi Darren,
        I did some movies with molden
        http://www.cmbi.kun.nl/~schaft/molden/molden.html
        and it was working fine at least on unix systems.

        I know that also gOpenMol is able to create
        movies but you will need a set of coordinates
        to create the "movement" (I think).
        http://www.csc.fi/~laaksone/gopenmol/gopenmol.html
        ciao
        Fabio
---|Fabio
Mariotti|--------o00o--<-><->--o00o----------------------------------
Department of Inorganic Chemistry   
http://www-chem.unifr.ch/ac/phd/fmariotti/
Univ Fribourg (Suisse) Perolles                 
mailto:[email-masked]
Tel: ++41 26 300 8752 Fax: ++41 26 300 9738

---
Darren Fayne
          College phone:      00-353-1-7048193
          Mobile:                 086-8304090
          Alternative E-mail: [email-masked]
                                     [email-masked]
School of Chemical Sciences,
Dublin City University,
Dublin,
Eire.

Get your FREE Email and Voicemail at Lycos Communications - http://comm.lycos.com

---

From: Kenward Vaughan <[email-masked]>
Date: Sat, 22 Jul 2000 08:24:23 -0700

Sorry to also walk in on this a bit late, but a graphics modeling program I
particularly like is Spock by Jon Christopher
( http://quorum.tamu.edu/jon/spock ). It works on a number of platforms,
including Linux (my flavor :), and has very nice facilities to carry out a
variety of tasks, including the creation of movies.

Jon has been incredibly helpful over the past years whenever I had
questions, and I have been very impressed with the capabilities of his program.

Kenward Vaughan
Bakersfield College
(currently home for the summer :)

On Fri, Jul 21, 2000 at 06:29:31AM -0700, Darren Fayne wrote:
> Hi cclers,
>     I have just noticed Damian Scherlis' question and it occurred to me that 
      I had never posted a summary of an enquiry I had sometime back. Apologies 
      to anyone who was eagerly awaiting it (particularily Anita)!!!
> 
> My initial question
> 
>   Hi all,
>     I've a quick question for you guys. I am wondering how to create a movie 
         of   a molecule that I have rotated and moved for inclusion in a 
         PowerPoint presentation?
> Unfortunately I did not have much time to delve into all the different 
         options available but what worked well for me was screen capturing the 
         image of my molecule as I slowly rotated/moved it. Paintshop Pro 
         converted the rgbs to jpgs. Then the Paint Shop Pro 6 animation shop 
         was used to piece the images together and create an avi.
> Here is the replies that I received for which I am very grateful.

...

-- 
Hi! I'm a .signature virus! Copy me into your ~/.signature, please!
--