Subject: Re: CCL:Compiling the NBO program.

From: "Bruce. Tattershall" <[email-masked]>
Date: Wed, 13 Sep 2000 09:32:40 +0100 (GMT)

Otavio:

 I have successfully changed MAXBAS to 999 in the NBO module of g94 and of
g98, l607.  One had to go through the .f source with an editor, and change
every PARAMETER statement containing MAXBAS, of which there are many. 
We were caught out by two little traps left in the code in both versions.
 (a) MAXBAS is spelled with mixed upper and lower case letters in at least
one routine, while it is in all upper case in others.  A case-insensitive
editor must be used for searching.
 (b) In some cases, one or two spaces have been left around the = in 
MAXBAS=500, so a global replacement of MAXBAS=500 is not sufficient.

 I have not tried to change MAXATM.

   Bruce

Personal Email: [email-masked]
    Dr. B.W. Tattershall
    Department of Chemistry, University of Newcastle, England

---

From: Marco Milanesio <[email-masked]>
Date: Wed, 13 Sep 2000 16:47:50 +0200 (MET DST)

Dear all,
I am sorry I can not give any answer to your question,
because I have a problem compiling the original version of NBO4.0

In fact I'm trying to substituite the original l607.exe in g98A7 with the
NBO4.0 (october 1999 version) on a SGI with 4 procs and 7.3.0 fortran 
compiler.  I was not able to build the new l607.exe.

AT first I enabled the UNIX version following the
instructions at page A10 of NBO4.0 manual and all worked well 
and I've got my new l607.F After this I tried
to build the new l607.exe with "bsd/bldg98 linkrest l607.exe" as 
described in appendix 2.2 of the NBO4.0 manual, but if finished with this 
error: a - ihtyp.o 
a -initwt.o 
a - intrn.o 
a - ioinqr.o 
a - ionic.o 
a - iontst.o 
a - iwprj.o 
a -jacobi.o 
a - jobopt.o 
a - kekule.o 
a - keyerr.o 
a - keypar.o 
a - [l-zL-Z]*.o
        rm -f -r temp-l607
        bsd/fixlib l607.a `main.a' is up to date. 
        f77 -nocpp -w -i8 -r8 -mips4 -64 -align64 -r10000 -mp -G 0 -O3
-LNO:blocking=OFF:prefetch=1 -r8const
-OPT:roundoff=3:IEEE_arithmetic=3:IEEE_comparisons=1:liberal_ivdep=TRUE:Olimit=0:reorg_common=OFF
-o l607.exe ml607.o l607.a util.so -mp -lblas_mp -lfastm *** Error code 2
(ignored)
        rm -f ml607.o 

Could anyone help me in solving this problem? 

Thank you so much 
Marco

Marco Milanesio
[email-masked]