Subject: Linda,Gaussian, pgcc and pgf77

From: Javier Eduardo Cuervo Sanchez <[email-masked]>
Date: Tue, 31 Oct 2000 08:34:26 -0400 (GMT)

Hello:

We have adquired an evaluation license of Linda for Linux to probe
Gaussian 98 in parallel in a cluster beowulf machine.

We have compiled and ran the tests in $LINDA/common/cl-examples and 
$LINDA/common/fl-examples using the compilers of GNU and all works were O.K.!

Gaussian 98 must be compiled with Portland Group's
compilers (pgcc and pgf77), the compilation is O.K. but when we trying to
probe the parallel test of gaussian 98, its have problems (don't finalize).
Equal ocurr when we trying to run the different tests in 
$LINDA/common/cl-example and $LINDA_PATH/common/fl-examples using pgcc and 
pgf77, we have some problems.

We have compiled and ran the different tests (employing pgcc and pgf77) using 
this configuration:  

1.) Set the next environment variables to:
    setenv LINDA_CC pgcc
    setenv LINDA_CC_LINK pgcc
    setenv POSTCPP_CC pgcc
    setenv LINDA_FORTRAN pgf77
    setenv POSTFL_FORTRAN pgf77
    setenv LINDA_FORTRAN_LINK pgf77

2.) Recompiled the cmain.o and fmain.o modules in $LINDA_PATH/lib
   (If we not recompiled this modules the examples can't be compiled succefully)

The results obtained (compiling and running the examples) the linda examples 
were:

1.) In the directory fl-examples (Fortran):
    a. Compiling: O.K.!
    b. Running: exited abnormally:
     [modim@chama1 fl-examples]$ ntsnet fping
     ntsnet: using executable file /temporal/modim/Pruebas/fl-examples/fping
     ntsnet: trying to schedule 3 workers
     ntsnet: scheduled a total of 3 workers
     ntsnet: starting master process on chama1.ula.edu.ve
     ntsnet: starting 1 worker on chama2.ula.edu.ve
     ntsnet: starting 1 worker on chama3.ula.edu.ve
     ntsnet: starting 1 worker on chama4.ula.edu.ve
     Floating exception
     ntsnet: master process exited with signal 11
     Floating exception
     Floating exception
     Pollable event occured

     [modim@chama1 fl-examples]$ ntsnet fhello
     ntsnet: using executable file /temporal/modim/Pruebas/fl-examples/fhello
     ntsnet: trying to schedule 3 workers
     ntsnet: scheduled a total of 3 workers
     ntsnet: starting master process on chama1.ula.edu.ve
     ntsnet: starting 1 worker on chama2.ula.edu.ve
     ntsnet: starting 1 worker on chama3.ula.edu.ve
     ntsnet: starting 1 worker on chama4.ula.edu.ve
     Floating exception
     ntsnet: master process exited with signal 11
     Floating exception
     Floating exception
     Pollable event occured

2.) On the another hand, in cl-examples (C):
    a. Compiling: Errors: 
/usr/local/sca/linda-5.0rh6.0/linux-2.2/bin/clc -g -o fastloop fastloop.cl
clc (V5.0 Network)
PGC-W-0251-Extraneous tokens ignored following # directive (__lt12027.c: 15)
....
PGC-W-0251-Extraneous tokens ignored following # directive (__lt12027.c: 643)
PGC-S-0035-Syntax error: Recovery attempted by replacing identifier __const by t
ypedef id .Z0000 (/usr/include/libio.h: 271)
PGC-W-0114-More than one type specified (/usr/include/libio.h: 271)
PGC-S-0040-Illegal use of symbol, __const (/usr/include/stdio.h: 124)
PGC-S-0040-Illegal use of symbol, __const (/usr/include/stdio.h: 126)
PGC-S-0035-Syntax error: Recovery attempted by replacing identifier __const by t
ypedef id .Z0001 (/usr/include/stdio.h: 126)
....

Please, Could you help me to configure correctly linda and gaussian 98 with
pgcc and pgf77 ?

Thanks in Advance,

Javier Cuervo
CeCalCULA

---

From: "Phillip D. Matz" <[email-masked]>
Date: Tue, 31 Oct 2000 10:20:09 -0800

Hi,

WARNING!  This is a lengthy email filled mostly with examples of what to "EXACTLY" type into certain files in RedHat6.2.  I apologize for the length in advance!

Let me tell you what I have found to work for me with the whole G98-LINDA-LINUX combintaion:

in the file "/etc/profile" make sure you have the following appended:
####
export LINDA_PATH=/usr/sca/linda-5.0rh6.0/linux-2.2/
export LINDA_FORTRAN=pgf77
export LINDA_FORTRAN_LINK=pgf77
export POSTFL_FORTRAN=pgf77
export PATH=/usr/sca/linda-5.0rh6.0:$PATH
export PATH=/usr/sca/linda-5.0rh6.0/common/bin:$PATH
export PATH=/usr/sca/linda-5.0rh6.0/common/lib:$PATH
export PATH=/usr/sca/linda-5.0rh6.0/linux-2.2/bin:$PATH
export PATH=/usr/sca/linda-5.0rh6.0/linux-2.2/lib:$PATH
####

in the file "/etc/hosts.equiv" make sure you have your nodes defined (example):
####
onea.chem.wsu.edu
oneb.chem.wsu.edu
onec.chem.wsu.edu
oned.chem.wsu.edu
####

in your "$HOME/.rhosts" file make sure you have your nodes and user defined:
####
onea.chem.wsu.edu administrator
oneb.chem.wsu.edu administrator
onec.chem.wsu.edu administrator
oned.chem.wsu.edu administrator
####

in your "$HOME/.cshrc" file append the following:
####
g98root=/usr
gr=$HOME
if [ "$g98root" ]
then gr=$g98root
fi
GAUSS_EXEDIR="$gr/g98/bsd:$gr/g98/private:$gr/g98"
GAUSS_ARCHDIR="$gr/g98/arch"
GMAIN=$GAUSS_EXEDIR
PATH=$PATH:$GAUSS_EXEDIR
LD_LIBRARY_PATH=$GAUSS_EXEDIR
export GAUSS_EXEDIR GAUSS_ARCHDIR PATH GMAIN LD_LIBRARY_PATH
G98BASIS="$gr/g98/basis" ; export G98BASIS
####

in your file "$HOME/.bashrc" append the following:
####
g98root=/usr
export g98root
PATH=/usr/sca/linda-5.0rh6.0/linux-2.2/lib:$PATH
PATH=/usr/sca/linda-5.0rh6.0/linux-2.2/bin:$PATH
PATH=/usr/sca/linda-5.0rh6.0/common/lib:$PATH
PATH=/usr/sca/linda-5.0rh6.0/common/bin:$PATH
gr=$HOME
if [ "$g98root" ]
then gr=$g98root
fi
GAUSS_EXEDIR="$gr/g98/bsd:$gr/g98/private:$gr/g98"
GAUSS_ARCHDIR="$gr/g98/arch"
GMAIN=$GAUSS_EXEDIR
PATH=$PATH:$GAUSS_EXEDIR
LD_LIBRARY_PATH=$GAUSS_EXEDIR
export GAUSS_EXEDIR GAUSS_ARCHDIR PATH GMAIN LD_LIBRARY_PATH
G98BASIS="$gr/g98/basis" ; export G98BASIS
LINDA_FORTRAN=pgf77
export LINDA_FORTRAN
LINDA_FORTRAN_LINK=pgf77
export LINDA_FORTRAN_LINK
POSTFL_FORTRAN=pgf77
export POSTFL_FORTRAN
####

After a quick reboot, you are now ready ready to for some fun.  Assuming you have a standard installation of g98 in /usr and you have a typical unaltered installation of LINDA in /usr/sca then remove just the fmain.o file (as SU):
####
rm -fv /usr/sca/linda-5.0rh6.0/linux-2.2/lib/fmain.o
chmod -v a+rwx /usr/sca/linda-5.0rh6.0/linux-2.2/lib
chmod -vR a+rw /usr/sca/linda-5.0rh6.0/common/lib
####

Now, run the following

####
cd /usr/sca/linda-5.0rh6.0/linux-2.2/lib/
pgf77 -c fmain.f
cd $g98root/g98
make -f bsd/g98.make linda
####

Assuming you have set up your "tsnet.nodes" file you should now be able to run G98L.

This routine is an agglomeration of a years worth of advice collected >from Gaussian support help, RedHat forums and SCA technical support.  It works for me, I can't guarentee it twill work for you.  Also, do not be too suprised if some of the stuff above is not necassary.  This solution is far from elegant, and I basically stopped tweaking it once I finally got it to work!

Respectfully,
Phillip Matz
[email-masked]

----- Original Message ----- 
From: "Javier Eduardo Cuervo Sanchez" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 31, 2000 4:34 AM
Subject: CCL:Linda,Gaussian, pgcc and pgf77 

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
>