Subject: Re: CCL:programming language

From: "Tamas E. Gunda" <[email-masked]>
Date: Thu, 1 Feb 2001 08:58:56 +0100

It would be difficult to answer in one word. If more or less serious programming is concerned,
C/C++. An easier entry is Visual Basic, it is more convenient for small tasks. On the other hand,
if somebody has some basic knowledge of VB, the Visual Basic-based scripts and macros of World, Excel etc
are within easy understanding and usage.

Dr Tamas E. Gunda
Research Group for Antibiotics of the Hungarian Acad. Sci.
University of Debrecen, POBox 36
H-4010 Debrecen, Hungary
tel.: (+36-52) 512 900/2472
fax: (+36-52) 512 914
e-mail: [email-masked]
home-page: www.klte.hu/~gundat/gunda.htm

----- Original Message ----- 

Subject: CCL:programming language

> 
> We are a chemistry department and our first year students take a computer
> science cours learning JAVA. They told me that they don't think it is of
> any use to them.
> 
> I would like to collect opinions which programming language is most useful
> for chemists. Let's assume they are learning only one. 
> 
> Thanks,
> Ulrike Salzner
> 
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 
>

---

From: <[email-masked]>
Date: Thu, 1 Feb 2001 10:05:28 +0000

As an addendum, a colleague also suggested as a tool which will have greater use
in terms of employability is SQL. Generally we all agreed though that the most
important principle is to teach people HOW to program - the actual language is
less important.

Scott Owens

"Dr. Richard Wood" <[email-masked]> on 31/01/2001 15:12:51

To:   [email-masked]
cc:    (bcc: Scott L Owens/R&T/Risley/BNFL)
Subject:  CCL:programming language

---

From: "Dr Mark J. Biggs" <[email-masked]>
Date: Thu, 01 Feb 2001 09:05:30 +0000

There is often too much emphasis placed on "the language".

Which language is taught is much less relevent than the need for them to learn about programming concepts (all
the way from recursive execution through to OO through to debugging/quality concepts) and how to tack problems
in a logical way.

If you get those two things right, the average student should have no problems picking up any language.

"Anthony J. Duben" wrote:

> I hope that this discussion does not become a religiouswar, but I believe that any modern language would be
> quite suitable -- C, FORTRAN, C++, JAVA -- are all good
> candidates.  You are not training chemists to maintain
> legacy code (much of which is in FORTRAN, plenty is in C,
> and some more in C++).  You want the students to learn
> how to think algorithmically.  JAVA is a good candidate
> because of its object-orientation is more thoroughly
> part of it than C++.  By the time the students graduate
> and maybe finish grad school, whatever language they learn
> now will have gone through another 3 editions.
>
> So, I would urge the students to get on with it and
> really work hard at it.  The hardest computer language
> to learn is the first one in which they need to learn
> how to think in algorithms.  The next one to learn is
> a lot easier.
>
> Anthony J. Duben ([email-masked])
>
> ********************************************************
> Anthony J. Duben
> Professor and Chairman
> Computer Science Dept., MS 5950
> Southeast Missouri State University
> 1 University Plaza
> Cape Girardeau MO 63701-4799
> phone:  573-651-2194
> fax:         573-651-2791
> e-mail: [email-masked]
>   or        [email-masked]
>
> "Education is not the filling of a pail
>   but the lighting of a fire."
>                   -- William Butler Yeats
>
> "Amateurs talk strategy;
>  professionals talk logistics."
>                        -- Gen. Omar N. Bradley
>
>

---

From: <[email-masked]>
Date: Thu, 1 Feb 2001 09:58:17 +0000

Hi there,

probably offering an unusual standpoint here and I know that this message weill
probably cause the usual c vs fortran arguments, but from and industrial
perspective and in terms of producing students that will have the most
appropriate programming skills no matter what area they move into (most students
do NOT go on to do programming based research). My offer on this would be Visual
Basic. Most people I asked in our group have used visual basic and spreadsheet
macros, whereas only 3 out of 17 have used C (or a variant) and only 2 have used
Fortran. So you want to produce students with the correct skills they will need
to use, data manipulation is more important to all students than either C or
fortran programming.
Just my humble opinion (which I am sure will be completely ignored by most
academic depts as Visual Basic is proprietory and not trendy enough).

Scott Owens

To:   [email-masked]

---

From: Don Steiger <[email-masked]>
Date: Thu, 1 Feb 2001 13:21:02 -0800

On Wed, 31 Jan 2001, Jim Phillips wrote:

> Hi,
> 
> I would say FORTRAN is the default scientific programming language because
> plain vanilla FORTRAN compiles just about everywhere.  Of course, with a
> language like Java it will run the same everywhere as well whereas FORTRAN
> leaves behaviors like aliasing undefined.  FORTRAN also teaches bad
> programming practices like fixed size arrays, global data, and all caps.
> 
This may be true about FORTRAN77 but it is definitely not true about
FORTRAN90/95.  The handling of global data and the dynamic manipulation of
array size is at least as good in FORTRAN90/95 as it is in C/C++.  The
only reason not to use FORTRAN90/95 in large numerical simulations is that
it will soon become extinct because nobody is using it.