Subject: Athlon vs. PIII

From: "Ole W. Saastad" <[email-masked]>
Date: Tue, 20 Feb 2001 14:36:41 +0100

I have run a few tests to check the performance of
Athlon vs. PIII. 
The Atlas (tuned BLAS libs) tests suggest very high 
performance for Athlon, however in real tests like
Gaussian 98 there is little difference. 

Summary of performance Athlon vs. PIII 

- with Gaussian98 runs.

pgf77 (cache size 512k)
Athlon:  22 minutes 26.8 seconds.
PIII:    17 minutes 57.3 seconds.

pgf77 (cache size 64k)
Athlon:  23 minutes  5.8 seconds.
PIII:    17 minutes 56.3 seconds.

-with Whetstone runs

g77 (Compiled for Athlon) (See below)
Athlon: Double Whetstone KIPS  602410
PIII:   Double Whetstone KIPS  574713

g77 (Compiled for Pentium)
Athlon: Double Whetstone KIPS  602410
PIII:   Double Whetstone KIPS  581395

Detailed results:

Compiled with pgf77.

pgf77  -O2 -tp p6 -Munroll -Mvect=cachesize:524288 -c redund.f
Cache size 512k.
Included Blas code compiled. 
 
: ole@pgs1-11:g98-work; g98/g98 form.com
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 799.665
cache size      : 256 KB

 SCF Done:  E(UB+HF-LYP) =  -190.288331671     A.U. after   10 cycles
 Job cpu time:  0 days  0 hours 17 minutes 58.6 seconds.
 Job cpu time:  0 days  0 hours 17 minutes 57.3 seconds.

: ole@pc-10:g98-work; g98/g98 form.com
model name      : AMD Athlon(tm) Processor
stepping        : 1
cpu MHz         : 807.203
cache size      : 64 KB

 SCF Done:  E(UB+HF-LYP) =  -190.288331671     A.U. after   10 cycles
 Job cpu time:  0 days  0 hours 22 minutes 29.0 seconds.
 Job cpu time:  0 days  0 hours 22 minutes 26.8 seconds.

Athlon run PIII code almost as good as PIII. However, the cache
size for Athlon is not 512k as PII but 64k.

Compiled with pgf77.

pgf77 -O2 -tp p6  -Munroll -Mvect=cachesize:65520 -c unfchk.f
Cache size 64k.
Included Blas code compiled.

: ole@pgs1-11: g98-work; g98/g98 form.com
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 799.665
cache size      : 256 KB

 SCF Done:  E(UB+HF-LYP) =  -190.288331671     A.U. after   10 cycles
 Job cpu time:  0 days  0 hours 17 minutes 56.3 seconds.

: ole@pc-10:g98-work; g98/g98 form.com
model name      : AMD Athlon(tm) Processor
stepping        : 1
cpu MHz         : 807.203
cache size      : 64 KB

 SCF Done:  E(UB+HF-LYP) =  -190.288331671     A.U. after   10 cycles
 Job cpu time:  0 days  0 hours 23 minutes  5.8 seconds.

Whetstone benchmark:

pc-10:
model name      : AMD Athlon(tm) Processor
stepping        : 1
cpu MHz         : 807.203
cache size      : 64 KB

pgs1-11:
model name      : Pentium III (Coppermine)
stepping        : 3
cpu MHz         : 799.665
cache size      : 256 KB

g77 -o  whetstoned.exe -s -O3 -fomit-frame-pointer -Wall -mathlon
-mcpu=athlon -march=athlon -malign-functions=4 -funroll-loops
-fexpensive-optimizations -malign-double -fschedule-insns2
-mwide-multiply  whetstoned.f

ole@pc-10:f77;whetstoned.exe (Athlon)

 Benchmark #2 -- Double Precision Whetstone (A001)
  Double Whetstone KIPS  602410
ole@pc-10:f77; 

ole@pgs1-11:f77;whetstoned.exe (PIII)
  Double Whetstone KIPS  574713
ole@pgs1-11:f77; 

g77 -o  whetstoned.exe -s -O3 -fomit-frame-pointer -Wall -mpentium
-mcpu=pentium -march=pentium -malign-functions=4 -funroll-loops
-fexpensive-optimizations -malign-double -fschedule-insns2
-mwide-multiply  whetstoned.f

: ole@pc-10:f77;whetstoned.exe (Athlon)

 Benchmark #2 -- Double Precision Whetstone (A001)
  Double Whetstone KIPS  602410
ole@pc-10:f77;

ole@pgs1-11:f77;whetstoned.exe (PIII)
  Double Whetstone KIPS  581395
ole@pgs1-11:f77; 

gcc patched with patches from the web site:

http://www.athlonlinux.org/

-- 
Ole W. Saastad, Dr.Scient.        mailto:[email-masked]
Scali, Scalable Linux Systems     http://www.scali.com

Olaf Helsets Vei 6                tel:    +47 22 62 89 68 (direct)
P.O.Box 70 Bogerud                fax:    +47 22 62 89 51        
N-0621 Oslo                       tel:    +47 22 95 21 45 (home)
NORWAY

---

From: Troy Baer <[email-masked]>
Date: Tue, 20 Feb 2001 10:59:03 -0500

> PIII:    17 minutes 56.3 seconds.
[snip]
> pgf77  -O2 -tp p6 -Munroll -Mvect=cachesize:524288 -c redund.f
             ^^^^^^
> Included Blas code compiled. 

Compiling with "-tp p6" is arguably the wrong thing to do on an Athlon, if
that's what you did.  Try either compiling with "-tp athlon" on the Athlon
or leaving out the -tp flag altogether (the compiler is supposed to figure
out what processor it's on if it's not specified).

Also, enabling prefetching (-Mvect=prefetch) may improve performance by
10-15% on both the Pentium III and the Athlon.

	--Troy
-- 
Troy Baer                       email:  [email-masked]
Science & Technology Support    phone:  614-292-9701
Ohio Supercomputer Center       web:  http://oscinfo.ccl.net

---

From: "Victor Anisimov" <[email-masked]>
Date: Tue, 20 Feb 2001 18:17:03 +0100

Dear Dr. Saastad,

> model name      : AMD Athlon(tm) Processor

Great work. However with such a drastical difference in cache size
these tests have very little sense. What you have measured should be
qualified as cache misses but not Athlon CPU speed.

With kind regards,
Victor.

==========================================================================
Victor Anisimov, PhD, Senior Software Researcher - Computational Chemist
FQS Poland, ul. Starowislna 13-15, 31-038 Krakow, Poland
Email: [email-masked]  Tel.(+48 12) 429-4345  Fax(+48 12) 429-6124
==========================================================================

----- Original Message -----
From: Ole W. Saastad <[email-masked]>
To: <[email-masked]>; CCL <[email-masked]>
Sent: Tuesday, February 20, 2001 2:36 PM
Subject: CCL:Athlon vs. PIII

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
[email-masked]

---

From: Patrick Geoffray <[email-masked]>
Date: Tue, 20 Feb 2001 13:11:27 -0500

Luc Vereecken wrote:

> As far as my G98 tests go, running the -tp p6 version on an athlon is about
> as fast as the -tp athlon. Same for the the -Mvect=prefetch flag.  I never
> managed to get Atlas compiled into G98 ? I use the pgf blas/lapack now due
> to compilation problems and lack of time to look into it.

Hi Luc,

the Blas library in LAPACK is a reference implementation.
It is not optimized and sucks big time : it's just a model of the
functions performed by the library. The performance of ATLAS is
much (MUCH) better.

I would advise you to find the time to look into it :-))

Cheers.

-- 
Patrick Geoffray

---------------------------------------------------------------
|      Myricom Inc       |  University of Tennessee - CS Dept |
| 325 N Santa Anita Ave. |   Suite 203, 1122 Volunteer Blvd.  |
|   Arcadia, CA 91006    |      Knoxville, TN 37996-3450      |
|     (626) 821-5555     |      Tel/Fax : (865) 974-0482      |
---------------------------------------------------------------

---

From: Brian Haymore <[email-masked]>
Date: Tue, 20 Feb 2001 08:49:29 -0700

Ole,
	Your results on Gaussian are interesting in that I see just the
opposite.  With Atlas we see about a 20-30% performance gain with the
athlon over the Piii line.

"Ole W. Saastad" wrote:
> _______________________________________________
> Beowulf mailing list, [email-masked]
> To change your subscription (digest mode or unsubscribe) visit http://www.beowulf.org/mailman/listinfo/beowulf

-- 
Brian D. Haymore
University of Utah
Center for High Performance Computing
155 South 1452 East RM 405
Salt Lake City, Ut 84112-0190

Email: [email-masked] - Phone: (801) 585-1755 - Fax: (801) 585-5366

---

From: Luc Vereecken <[email-masked]>
Date: Tue, 20 Feb 2001 18:44:50 +0100

>At 10:59 20/02/01 -0500, Troy Baer wrote:

Luc Vereecken