Subject: *maintainence of sun.sparc solaris8

From: sohail qamar <[email-masked]>
Date: Sat, 24 Feb 2001 20:35:12 -0800 (PST)

I am posting this to ccl ,might be some person know
the answer.Though its not relateed to chemistry but
still there are friends who are working with unix
(solaris)

I was runing mpich (message passing interface
programme on sun.sparc solaris8 when I by mistake
change the name of /usr/lib to
/usr/lib/lib_rename-mpich.After which the system is
not responding to any of the commands except pwd cd
echo export .The system is requiring /usr/lib/ld.so.1
(i forget actual name).any how is there any way that i
can rename /usr/lib_rename-mpich to /usr/lib

any suggestion.
Thanks
sohail.

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

---

From: Jan Labanowski <[email-masked]>
Date: Sun, 25 Feb 2001 00:49:38 -0500 (EST)

if you cannot do 
   mv /usr/lib/lib_rename-mpich /usr/lib

I do not see much chance beside:

1) remove the hard drive from your solaris sparc.
2) change its SCSI ID to something high, say 4 with jumpers which
   should be on the drive.
3) Take a PC case, or external disk case, a scsi cable (assuming that
   you have one)
4) Power down some other sparc station. Attach the drive to this machine
   and boot. The machine should recognize the drive during boot, and
   give you the device number. 

5) Make some mount point on the other machine, say, /mnt/mydisk

6) Enter the dev and mount point to /etc/vfstab (look how the other
   native drives to the machine are mounted), say
      /dev/dsk/c0t0d0s4 /dev/rdsk/c0t0d0s4 /mnt/mydisk ufs 1 no

   Then say:
     mount /mnt/mydisk

7) cd /mnt/mydisk/usr
   mv lib_rename-mpich lib

8) shutdown the machine, detach the disk, put it in the original
   machine, and reboot.

Jan

> can rename /usr/lib_rename-mpich to /usr/lib

Jan K. Labanowski            |    phone: 614-292-9279,  FAX: 614-292-7168
Ohio Supercomputer Center    |    Internet: [email-masked] 
1224 Kinnear Rd,             |    http://www.ccl.net/chemistry.html
Columbus, OH 43212-1163      |    http://www.ccl.net/

---

From: Peter Shenkin <[email-masked]>
Date: Sun, 25 Feb 2001 09:04:46 -0500 (EST)

Hi,

You could try setting LD_LIBRARHY_PATH to
/usr/lib/lib_rename-mpich.  For example, if you use csh or tcsh, try:

	setenv LD_LIBRARY_PATH /usr/lib/lib_rename-mpich

For ksh or bash, it would would be:

	export LD_LIBRARY_PATH=/usr/lib/lib_rename-mpich

If you're running a really minimal sh, it would be:

	LD_LIBRARY_PATH=/usr/lib/lib_rename-mpich
	export LD_LIBRARY_PATH

On launching an executable, the system looks for shared libraries
first in LD_LIBRARY_PATH, then in the "standard" places.

If you are still logged in and have a shell (and it sounds like
this is your situation), then you should be able set the env.
variable.

Good luck!
-P.

On Sat, 24 Feb 2001, sohail qamar wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
>