Subject: Re: CCL:Qmol: Molecular viewer for Windows

From: Rick Venable <[email-masked]>
Date: Fri, 16 Mar 2001 09:57:57 -0500

On Thu, 15 Mar 2001, J. D. Gans wrote:
> Qmol is a OpenGL based program for viewing molecular structures and
> animating molecular trajectories. It runs under Windows 95/98/NT/00 and
> supports the following features:
> 
> (*) Animate molecular trajectories stored in the DCD file format (both
> big- and little-endian). 

As a long time academic CHARMM user, it was *years* before it became
apparent to non-Quanta users that a DCD file was the MSI/Polygen name
for a CHARMM binary trajectory file.  We always referred to them as
"trajectory files", or .trj files, an extension in common usage prior to
CHARMm, the commercial variant.  I think it would be clearer if your
blurb referred to CHARMM/CHARMm explicitly, in addition to file
extension that has meaning mostly to Quanta users.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905   [email-masked]
ALT email:  [email-masked]
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=

---

From: Gerardo Andres Cisneros <[email-masked]>
Date: Fri, 16 Mar 2001 15:28:42 -0500 (EST)

Hello

A couple of weeks ago I posted a message asking for suggestions in getting
gaussian to run in parallel on a beowulf cluster.  Almost all replys
said to update the 2.2.16x kernel.  I've upgraded all the nodes to
2.2.17-14 but I still have the same problem.

Basically if I run g98 on a single processor the program runs great.  I've
ran several of the tests that come with g98's distro and the results are
the same.

However, when I use more than one node, if the job takes a lot of time,
invariably one of the slave nodes will run out of memory because g98 will
fail to kill the l*.exe processes on the slave nodes so I'll have a bunch
of phantom processes just taking up memory on the slave nodes.

Here's a small part of the output from using "setenv GAUSS_LFLAGS -vv"
with a parallel run in the cluster:

...
********************************************
node name:              rho3
official node name:     rho3.chem.duke.edu
config lookup name:     rho3
executable directory:   /usr/local/g98/linda-exe
executable name:        l701.exel
working directory:      /usr/execute/pbs
debugger:
linda rsh argument:     rsh
linda rcp argument:
user:
adjusted load:          1.000000
threshold:              20.000000
speedfactor:            1.000000
available:              True
nice:                   False
master:                 False
processes scheduled:    1
maximum processes:      1
********************************************
node name:              rho4
official node name:     rho4.chem.duke.edu
config lookup name:     rho4
executable directory:   /usr/local/g98/linda-exe
executable name:        l701.exel
working directory:      /usr/execute/pbs
debugger:
linda rsh argument:     rsh
linda rcp argument:
user:
adjusted load:          1.000000
threshold:              20.000000
speedfactor:            1.000000
available:              True
nice:                   False
master:                 False
processes scheduled:    1
maximum processes:      1
********************************************
node name:              rho5
official node name:     rho5.chem.duke.edu
config lookup name:     rho5
executable directory:   /usr/local/g98/linda-exe
executable name:        l701.exel
working directory:      /usr/execute/pbs
debugger:
linda rsh argument:     rsh
linda rcp argument:
user:
adjusted load:          1.000000
threshold:              20.000000
speedfactor:            1.000000
available:              True
nice:                   False
master:                 False
processes scheduled:    1
maximum processes:      1
********************************************
node name:              rho7
official node name:     rho7.chem.duke.edu
config lookup name:     rho7
executable directory:   /usr/local/g98/linda-exe
executable name:        l701.exel
working directory:      /usr/execute/pbs
debugger:
linda rsh argument:     rsh
linda rcp argument:
user:
adjusted load:          1.000000
threshold:              20.000000
speedfactor:            1.000000
available:              True
nice:                   False
master:                 False
processes scheduled:    1
maximum processes:      1
********************************************
ntsnet: starting master process on rho8.chem.duke.edu
/usr/sca/linda-5.0rh6.0/linux-2.2/bin/linda_sh
/usr/local/g98/linda-exe/l701.exel 0 reactrho2.chk 1
/usr/execute/pbs/scrdir/Gau-19346.int 0
/usr/execute/pbs/scrdir/Gau-19346.rwf 0
/usr/execute/pbs/scrdir/Gau-19346.d2e 0
/usr/execute/pbs/scrdir/Gau-19346.scr 0
/usr/execute/pbs/scrdir/Gau-19345.inp 0 junk.out 0 +LARGS -kainterval 1000
-master 18469 -tsnetport 22308 -maxworkers 5 -minworkers 5 -minwait 600
-maxwait 600 -nodename rho8.chem.duke.edu -kaon
ntsnet: starting 1 worker on rho2.chem.duke.edu
/usr/sca/linda-5.0rh6.0/linux-2.2/bin/linda_rsh rho2.chem.duke.edu -r rsh
/usr/local/g98/linda-exe/l701.exel +LARGS -chdir /usr/execute/pbs -worker
rho8.chem.duke.edu:18469 -workerwait 900 -tsnetref 1 -nodename
rho2.chem.duke.edu
ntsnet: starting 1 worker on rho3.chem.duke.edu
/usr/sca/linda-5.0rh6.0/linux-2.2/bin/linda_rsh rho3.chem.duke.edu -r rsh
/usr/local/g98/linda-exe/l701.exel +LARGS -chdir /usr/execute/pbs -worker
rho8.chem.duke.edu:18469 -workerwait 900 -tsnetref 2 -nodename
rho3.chem.duke.edu
ntsnet: starting 1 worker on rho4.chem.duke.edu
/usr/sca/linda-5.0rh6.0/linux-2.2/bin/linda_rsh rho4.chem.duke.edu -r rsh
/usr/local/g98/linda-exe/l701.exel +LARGS -chdir /usr/execute/pbs -worker
rho8.chem.duke.edu:18469 -workerwait 900 -tsnetref 3 -nodename
rho4.chem.duke.edu
ntsnet: starting 1 worker on rho5.chem.duke.edu
/usr/sca/linda-5.0rh6.0/linux-2.2/bin/linda_rsh rho5.chem.duke.edu -r rsh
/usr/local/g98/linda-exe/l701.exel +LARGS -chdir /usr/execute/pbs -worker
rho8.chem.duke.edu:18469 -workerwait 900 -tsnetref 4 -nodename
rho5.chem.duke.edu
ntsnet: starting 1 worker on rho7.chem.duke.edu
/usr/sca/linda-5.0rh6.0/linux-2.2/bin/linda_rsh rho7.chem.duke.edu -r rsh
/usr/local/g98/linda-exe/l701.exel +LARGS -chdir /usr/execute/pbs -worker
rho8.chem.duke.edu:18469 -workerwait 900 -tsnetref 5 -nodename
rho7.chem.duke.edu
ntsnet: waiting for linda group message
ntsnet: received linda group message: group has 6 members
malloc failed.: Cannot allocate memory
ntsnet: worker on node rho3.chem.duke.edu exited abnormally
ntsnet: beginning to shutdown remote processes
Killed by signal 15.
Killed by signal 15.
Killed by signal 15.
Killed by signal 15.
ntsnet: shutting down with return code 143

[1]  + Exit 1                        g98l react6p
823.210u 95.200s 19:14.68 79.5% 0+0k 0+0io 397099pf+6w

Even though the console output says it shuts down remote processes by
signal 15 it really doesn't.

react6p is a QST3 caculation using HF/3-21G* that running on a single
processor alpha took 32 minutes (local test).

Has anybody had a similar problem?.

Thanks in advance,

Andres

--
G. Andres Cisneros
Department of Chemistry
Duke University
[email-masked]

---

From: "Phillip D. Matz" <[email-masked]>
Date: Fri, 16 Mar 2001 15:22:42 -0800

Hello Andres,

Curious.  I run G98 + Linda + RH6.2 with the 2.2.16-3 kernel without these
errors, so maybe I could try your particular input file and see if I can
reproduce the error you are getting.  I do not understand why your
particular installation of G98 + Linda is failing to kill the l*.exel
processes on the slave nodes, I haven't experienced this yet.  Maybe you
should ask the Beowulf listers if they have come across this error with G98L
on their clusters.

I have experienced the particular error that you see at the end of your
output file ( malloc failed.: Cannot allocate memory) but I doubt my problem
is related to yours.  My problem turned out to be an improper (i.e. none
;) ) grounding of my network card and motherboard which would gradually lead
up to the point that enough static electricity would gather on the network
card to cause the computer to hang - yeah I know, not a good thing...  But
your problem sounds like a software issue (my personal opinion with
absolutely no technical merit).

Respectfully,

Phillip Matz
[email-masked]

----- Original Message -----
From: "Gerardo Andres Cisneros" <[email-masked]>
To: <[email-masked]>
Sent: Friday, March 16, 2001 12:28 PM
Subject: CCL:Gaussian on beowulf cluster

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
[email-masked]