Subject: trouble compiling Autodock3.0.5 for Linux

From: Antoine <[email-masked]>
Date: Mon, 19 Mar 2001 15:36:24 +0100

Dear CCLers,

I downloaded Autodock3.0.5 last week and can't compile the Autogrid part
under linux (mdk 7.02 uptodated) because of an error in main function.
Here is the message :

main.c: In function `main':
main.c:106: `XYZ' undeclared (first use in this function)
main.c:106: (Each undeclared identifier is reported only once
main.c:106: for each function it appears in.)
make: *** [main.o] Error 1

Big bug but did someone download that soft and compile it for linux or
have the same problem ? Is there a known fix ?

Thank you very much for any answer.

Antoine FORTUNE

--
----------------------------------------------
Antoine FORTUNE

Ingénieur Modélisation Moléculaire

Département de Pharmacologie Moléculaire - DPM
UMR 5063 - Universite Joseph Fourier
Domainde de la Merci 38706 LA TRONCHE - FRANCE

Tel :  +33 4 76 63 71 40
Fax :  +33 4 76 51 86 67
e-mail : [email-masked]
ICQ : 106018150
----------------------------------------------

---

From: Mikael Johansson <[email-masked]>
Date: Mon, 19 Mar 2001 18:34:23 +0200 (EET)

Hello Antoine and All!

> main.c:106: `XYZ' undeclared (first use in this function)

The simplest procedure is to edit the autocomm.h file. Find the
declaration
#define SPACE        3

and add the following line for example under it:
#define XYZ          3

Apparently the variable name has changed between versions, but not at
every location.

Have a nice day,
    Mikael Johansson
    University of Helsinki
    Department of Chemistry