Subject: AutoDock/LINUX

From: Christian Pilger <[email-masked]>
Date: Tue, 20 Mar 2001 12:36:17 +0100

Dear CCLers,

	I have a question about the script "mol2topdbq" that comes with
AutoDock 3.0.5. I changed the "nawk" in the very beginning to the
awk-version I'm using on my PC (Suse Linux 7.1) "gawk", but this scripts
does not work properly - upon exeution, I get the following message:

gawk: cmd. line:33: fatal: expression for `<' redirection has null string
value

When I use the very same input mol2-file on our SGI, the same script
(apart from nawk/gawk) works without any problems. Did anybody experience
something similar and can give me a hint on how to fix it ?

Ciao,

Christian

-----------------------------------------------------------------

 Dr. Christian Pilger 

    Istituto di Strutturistica Chimica "Giordano Giacomello"
    C.N.R. - Sezione di Trieste
    Area Science Park - Basovizza
    Strada Statale 14 - Km. 163.5
    I-34012 Trieste/Italy

   Tel.: +39+040+226881
   Fax : +39+040+9221126
 e-mail: [email-masked]
 
-----------------------------------------------------------------

---

From: Jarrod Smith <[email-masked]>
Date: Tue, 20 Mar 2001 10:12:44 -0600

> gawk: cmd. line:33: fatal: expression for `<' redirection has null string

Try changing "nawk" to "gawk --traditional" and see if that helps.

--
Jarrod A. Smith
Research Asst. Professor, Biochemistry
Asst. Director, Center for Structural Biology
Computation and Molecular Graphics
Vanderbilt University