Subject: normal inquiry

From: Guangping_Li/CAS/UNO/[email-masked]
Date: Fri, 11 May 2001 09:56:51 -0500

Dear friends:

   Does anyone know of any software which can be used to extract the amino
sequence of a peptide from a PDB (protein data bank) file?

   I'm looking for several experimental peptide PDB files for demonstration too,
and these peptides better have 10-20 amino residues.

   Thanks for your help.

   Jim

---

From: Konrad Hinsen <[email-masked]>
Date: Fri, 11 May 2001 20:23:10 +0200

> sequence of a peptide from a PDB (protein data bank) file?

Get Python (www.python.org) plus Scientific Python
(http://dirac.cnrs-orleans.fr/programs/scientific.html)
and then use the following script:

--------------------------------------------------
> from Scientific.IO.PDB import *
import sys

s = Structure(sys.argv[1])
for chain in s.peptide_chains:
    print s.sequence()
--------------------------------------------------

Run as "python script.py pdb_file", where script.py is the name of
the small script file shown above.
-- 
-------------------------------------------------------------------------------
Konrad Hinsen                            | E-Mail: [email-masked]
Centre de Biophysique Moleculaire (CNRS) | Tel.: +33-2.38.25.56.24
Rue Charles Sadron                       | Fax:  +33-2.38.63.15.17
45071 Orleans Cedex 2                    | Deutsch/Esperanto/English/
France                                   | Nederlands/Francais
-------------------------------------------------------------------------------

---

From: Asim Kumar Debnath <[email-masked]>
Date: Fri, 11 May 2001 11:38:44 -0400

Hi Jim:
    You can extract sequence of any pdb structure directly from the RCSB Protein
Data Bank site (http://www. rcsb.org/pdb/). When you search for a pdb file, it will
give you a Summary information page. The left side of the page will give you a
number of choices and the last one is "sequence details". If you click on that
item, it will show the sequence and download options. You can download that
sequence in FASTA format.
    Hope this helps.

Asim

Guangping_Li/CAS/UNO/[email-masked] wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

--

=======================================================================

             ***
             ***
            ****                Asim K. Debnath, Ph.D.
           ****                 Lindsley F. Kimball Research Institute
          ****  ***             The New York Blood Center
         ****    ****           310 E 67 Th Street
        ****  **  ****          New York, NY 10021
       ****  ****  ****         Tel. (212) 570-3373
      ****    **    ****        Fax. (212) 570-3299
       ****************         E-mail: [email-masked]
        **************

========================================================================