Subject: Compilation problems

From: "Gustavo Velardez" <[email-masked]>
Date: Tue, 22 May 2001 16:30:42 -0000

Hi everybody,
I am trying to compile G98 A.7 in a PC with Red Hat 7.1.  I have all the 
libraries and I followed all the instructions but I have the following 
error:

--------------------------------------------------------------------
bsd/mdutil.c: In function `etime_':
bsd/mdutil.c:2361: `CLK_TCK' undeclared (first use in this function)
bsd/mdutil.c:2361: (Each undeclared identifier is reported only once
bsd/mdutil.c:2361: for each function it appears in.)
bsd/mdutil.c: In function `fdate_':
bsd/mdutil.c:2374: warning: assignment makes pointer from integer without a 
cast
make: *** [mdutil.o] Error 1
ar rlv ../util.a mdutil.o
ar: mdutil.o: No such file or directory
endif
rm mdutil.o
rm: cannot remove `mdutil.o': No such file or directory
endif
...
...
pgf77   -O2 -tp p5 -Munroll -Mvect=cachesize:524288 -c ml0.f
rm -f ml0.f ml0.c
make[1]: Leaving directory `/home/gust/g98'
pgf77    -O2 -tp p5 -Munroll -Mvect=cachesize:524288 -o g98 ml0.o   util.so
/applx1/pgi/linux86/lib/libpgftnrtl.a(cnfg.o): In function 
`__fio_scratch_name':
cnfg.o(.text+0x33): the use of `tempnam' is dangerous, better use `mkstemp'
ml0.o: In function `MAIN_':
ml0.o(.text+0x2b1): undefined reference to `gauabt_'
...
...
util.so: undefined reference to `galloc1_'
make: *** [g98] Error 1
endif

--------------------------------------------------------------------
and the compilation is stopped.
What is the problem? Is there some library or something I have forgotten?

Thank you for your attention

Gustavo Velardez PhD
LCAR-IRSAMC. Université Paul Sabatier.
118 route de Narbonne. 31062. Toulouse. France.
TE: +33-(0)5-61-55-60-09
FAX:+33-(0)5-61-55-83-17

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: Ben Webb <[email-masked]>
Date: Tue, 22 May 2001 22:16:01 +0100 (BST)

> libraries and I followed all the instructions but I have the following

	This problem is caused by the change from Linux kernel 2.2 (as
used by RedHat 7.0 and earlier) to 2.4 (as used in RedHat 7.1). The fix is
simple: add the line "#include <time.h>" to bsd/mdutil.c (around about
line 195 should do).

	Hopefully, fixing this problem will also fix your other problems.
(If not, I can't help you further, because I don't observe these problems
on my system!)

	Ben
-- 
[email-masked]           http://bellatrix.pcl.ox.ac.uk/~ben/
"All science is either physics or stamp collecting."
	- Ernest (1st Baron) Rutherford