Subject: Re: CCL:Temperature fluctuation during a const T simulation

From: Konrad Hinsen <[email-masked]>
Date: Mon, 28 May 2001 17:11:35 +0200

> In molecular dynamics, there are a lot of techniques to keep the
> Temperature(T) constant, such as velocity scaling, NOSE heat bath,
> Langevin dynamics, and so on.

However, these techniques do not give equivalent results. Some
guarantee the correct thermodynamic averages in the NpT ensemble,
others only the correct averages for quantities that do not depend on
the momenta, and yet others not even that. No technique can generate
"correct" dynamics at constant temperature, it is not even clear what
exactly that means.

> However, as you know that the T can't always be a constant, but
> fluctuating around the input value.

It depends on what you call T. I suppose you mean the instantaneous
kinetic energy, which is indeed not constant. The quantity that you
should identify with the thermodynamic temperature is some long-time
average of the kinetic energy.

> about 50K). I think this will weaken any of my conclusions based on
> the simulation, especially for those temperature senstive
> quantuties.

Not necessarily. The kinetic energy is a fluctuating energy in the NpT
ensemble, and its fluctuations can even be calculated. If your
simulation uses the correct physical parameters (an ideal that is
never achieved, of course), then the fluctuations you get out must be
the correct ones.

Anyway, you cannot reduce the fluctuations without changing physical
parameters, and that is not necessarily a good idea.

Regards,
  Konrad Hinsen.
-- 
-------------------------------------------------------------------------------
Konrad Hinsen                            | E-Mail: [email-masked]
Centre de Biophysique Moleculaire (CNRS) | Tel.: +33-2.38.25.56.24
Rue Charles Sadron                       | Fax:  +33-2.38.63.15.17
45071 Orleans Cedex 2                    | Deutsch/Esperanto/English/
France                                   | Nederlands/Francais
-------------------------------------------------------------------------------

---

From: "Eduardo A. Menendez Proupin" <[email-masked]>
Date: Mon, 28 May 2001 10:32:49 -0400 (EDT)

Dear Mike and CCLers,

The temperature fluctuaction in the NVE ensemble is
<delta T^2>/T^2=2/3N,
where N is the number of atoms in your simulation. Check if your variance
sqrt(<delta T^2>)=50 K is in agreement with this formula. If it is, you
should increase N, or increase the simulation time, or run several
paralell simulations with independent initial configurations and average
them.

If you receive other answers, please, let know them. 

Regards,
Eduardo

On Fri, 25 May 2001, mike smith wrote:

> Dear listers,
> 
> In molecular dynamics, there are a lot of techniques
> to keep the Temperature(T) constant, such as velocity
> scaling, NOSE heat bath, Langevin dynamics, and so on.
> 
> However, as you know that the T can't always be a
> constant, but fluctuating around the input value.
> 
> I am doing a simulation by Langevin dynamics, and my
> trouble is that the T fluctuation of my results is
> very big (The variance of T is about 50K). I think
> this will weaken any of my conclusions based on the
> simulation, especially for those temperature senstive
> quantuties. 
> 
> Since I don't have much experience on Langevin
> dynamics, I am wondering if anyone could give me some
> help on how to MINIMIZE the temperature fluctuation
> for Langevin dynamics. Thanks a lot in advance.
> 
> Sincerely,
> 
> Mike Smith
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Auctions - buy the things you want at great prices
> http://auctions.yahoo.com/
> 
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 

 Eduardo Ariel Menendez Proupin, Ph.D.
 -------------------------------------
 Laboratorio de Ingenieria de Zeolitas
 Instituto de Materiales y Reactivos
 Universidad de La Habana
 San Lazaro y L.
 Vedado 10400
 La Habana, Cuba
 E-mail:[email-masked]
 Fax  : (53+7)+320018/794651  
 Phone: (53+7)+788950/788956/788957 ext 553
        (53+7)+707666/705707