Subject: summary: problem on memory.

From: "dwang" <[email-masked]>
Date: Mon, 13 Aug 2001 20:07:02 +0800

Hi all,

Some days ago I posted a problem about the distribution of memory and some warm-hearted cclers gave me some helpful advice. Many thanks to Mikael J., Dirk Dettmering, Peter Burger, Fredrick C. Hagemeister, Jim Kress. Following is the summary of my former question and all of the replies.

*****************my question*******************
I just bought a pc with p4 1.7G, 1G memory, asus mainboard(in the manual it can support memory up to 2G). OS is windows98. When i run Gaussian98, I can't set the memory distributed to G98 more than 250MB, and if I start the Norton Antivirous real-time scan, i can't run ms-dos because of low memory(information on the computer) but I think that no more than 500MB memory is used at the time. Where is the rest memory? If i remove 500MB memory, everything goes ok except that I still can't set the memory to G98 more than 250MB. Why??? Is it because of G98 or Win98? Any advices will be appreciated.
***************************Mikael J.***************
Windows 95/98/ME can not properly handle systems with more memory than 512MB. See http://support.microsoft.com/support/kb/articles/Q253/9/12.ASP You need Linux or Windows 2000.

********************Dirk Dettmering***************
It,s caused by your OS. You have an OS for Gaming not for Gamess (sorry for the comparison, but I couldn't resist)! Win95/98/Me can't use more than 512 MB but do get even slower above 256 MB (the reason for this ist the cache sizes).
Get a serious OS, preferably linux, but Windows NT can also cope with this amount of memory.

********************Peter Burger****************************
Problem is Win9x does not support more than 800 MB max. - it is a problem with the vcache device driver this number includes the AGP aperture size though.  - better get a license of WIN2K or NT4 their memory management is  superior anyways. check http://support.microsoft.com knowledge base Q253912

*****************Gregory Shamov***************************
AFAIK its because of Win98. Try Win2000. There are much more reasons to use Windows NT family instead of Win9x than 256MB memory limit in the latter. In fact, no one researcher I know is using Win9x for production calculations, because of its buggy and unstable nature.

**********************Fredrick C. Hagemeister*************************
The switch to Windows 2000 would also be good for speed and stability. There is a significant time savings going between G98W to Win2K.  Also, I think everyone will testify that Win2K crashes less than Win98.  On the other hand, I found a great free front end for Gaussian called WebMO (www.webmo.net) that requires Linux on the G98 machine.  It is a
server-based, web application.  The user interfaces with the server with any web browser anywhere and can visually construct, submit, and see the output from the jobs.

*********************Jim Kress*****************************
That's not really true.  If you read the article you'll see that 98/ME will work with > 512MB RAM, all you have to do is :

"Use the MaxFileCache setting in the System.ini file to reduce the maximum amount of memory that Vcache uses to 512 megabytes (524,288 KB) or less. "

I routinely run 768 MB of RAM under Windows ME using applications like pcGAMESS and have no problem getting all the memory I need.

Wang Dongqi

---

From: Roy Jensen <[email-masked]>
Date: Mon, 13 Aug 2001 12:02:12 -0700 (PDT)

A second question was asked as well, namely that G98W doesn't accept more
than 250MB in the default.route file. I also have hit this limitation and
assumed it to be due to G98W, akin to the single-processor and 2 GB
scratch file limitations. (A detailed discussion is available in the CCL
archives.)

Roy Jensen

---

From: "Jim Kress" <[email-masked]>
Date: Mon, 13 Aug 2001 16:48:59 -0400

I don't think250MB limit is correct.  I have routinely used 960MB for G98W
calculations in Windows NT.

You might be right if you said 250MW (i.e. mega words).  That would be 2GB
which is the limit for a 32bit addressing system like Windows.

Jim

----- Original Message -----
From: "Roy Jensen" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, August 13, 2001 3:02 PM
Subject: CCL:summary: problem on memory.

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
[email-masked]