Subject: automatic parallelization

From: Zilberman Silviu <[email-masked]>
Date: Thu, 29 Nov 2001 15:25:26 +0000

Hi everyone,

Does anyone has experience with using auotmatic parallelization tools,
for old Fortran and C codes?
We are buying a PC cluster, and I look for a quick and dirty way of
getting parallel codes out of seriel one.

Thanks,
Silviu Zilberman.

-- 
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
Zilberman Silviu

	School of Chemistry, Tel Aviv University
	Ramat Aviv, Tel-Aviv, Israel 61391

Phones
	972-3-6407634 (office)
	972-3-6409293 (fax 1 - School of Chemistry)
	972-3-6423765 (fax 2 - Prof. A. Nitzan)

mailto:[email-masked]
Home Page: http://femto.tau.ac.il/~silviu
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

---

From: Maurice Cafiero <[email-masked]>
Date: Thu, 29 Nov 2001 17:34:39 +0000

hello:
    I have used the automatic parallelization tools that come with SGI
Fortan, and they
are pretty terrible. They created a 2/3% speedup and were about 5%
parallel.
    I suggest 2 things:

    1) Use parallel numerical libraries. These are pre-existing and can
probably be downloaded
          from netlib.

    2) Learning basic MPI is not difficult at all for an experienced
FORTRAN programmer.
          I learned it in about 3 weeks and my code is 80/90% parallel.
I get excellent speedup
          (approximately linear with # procs).

What type of program are you trying to parallelize?

--
Mauricio Cafiero
Doctoral Candidate : Theoretical
                     and Computational
                     Quantum Chemistry
Department of Chemistry
University of Arizona