Subject: Any comparisons of LAM-MPI vs. MPI-CH on LINUX/86?

From: Christoph van Wüllen <[email-masked]>
Date: Tue, 15 Jan 2002 15:25:53 +0100

Are there any performance comparisons of the two free MPI-implementations
in the subject line on PC/Linux computers?
I tried both with a simple program sending and receiving blocks of different
size, and LAM-MPI was slightly ahead. This is however only a first hit, so
I wonder if there have been thorough comparisons.
Moreover, although MPI-CH is better supported on a broad range of platforms,
since MPI is assumed to be standard, is this a reason to prefer MPI-CH?

Yours,

+---------------------------------+----------------------------------+
| Prof. Christoph van Wüllen      | Tele-Phone (+49) (0)30 314 27870 |
| Technische Universität Sekr. C3 | Tele-Fax   (+49) (0)30 314 23727 |
| Straße des 17. Juni 135         | eMail                            |
| D-10623 Berlin, Germany         | [email-masked] |
+---------------------------------+----------------------------------+

---

From: Maurice Cafiero <[email-masked]>
Date: Tue, 15 Jan 2002 20:30:09 +0000

I really do not know too many of the technical aspects, but we had LAM
and MPICH on two different clusters.
The one with LAM has run smoothly for almost 3 years, while we had to
replace MPICH after 6 months due to instability.
If you want, I can ask our main sys admin to email you details...

--
Mauricio Cafiero
Doctoral Candidate : Theoretical
                     and Computational
                     Quantum Chemistry
Department of Chemistry
University of Arizona