Subject: how to convert .rdf to .sdf file?

From: Gao Ying <[email-masked]>
Date: Tue, 29 Jan 2002 14:39:49 +0800 (CST)

Dear CCLer,

Could you kindly tell me how to convert .rdf to .sdf file.
Is there any program to do such work?

Thanks in advance!

Gao Ying

---

From: Jonathan Brecher <[email-masked]>
Date: Tue, 29 Jan 2002 20:38:42 -0500

>Is there any program to do such work?

You can no more convert an .rdf file to an .sdf file than you can 
convert a cube to a square.  RD files contain data types that SD 
files cannot.  For more information, don't post to a mailing list -- 
go directly to the source (gee, have I said that before?) -- which in 
this case is http://www.mdli.com/downloads/ctfile/ctfile_subs.html

If you've *got* to do that conversion and you don't care how much 
data you lose, there are many programs that will do the conversion as 
best as the file formats will permit.  MDL's own ISIS/Base and our CS 
ChemFinder come to mind.  There are likely others, but it hardly 
matters given the circumstances.

Jonathan Brecher
CambridgeSoft Corporation
[email-masked]
--

---

From: Joseph Durant <[email-masked]>
Date: Tue, 29 Jan 2002 14:07:06 -0800

Hi!

In general the two file types are not interconvertable.  .rdf files normally
contain reactions and associated data, and .sdf files contain only molecules
with associated data.  You can only interconvert those .rdf files which contain
only molecules, with straightforward associated data.

You can get more information from the spec documents for the MDL file formats:

http://www.mdli.com/downloads/ctfile/ctfile_subs.html

Hope this helps.

Joe

Gao Ying wrote:
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

-- 
Joe Durant               [email-masked]                      
MDL Information Systems
14600 Catalina Street, San Leandro, CA 94577           
voice: (510) 357-2222 x 1331 or (510) 895-1313  FAX: (510) 614-3616          
--------------
If Bill Gates had a nickel for every time Windows crashed...
... oh wait, he does.