Subject: Re: CCL:G98 Dual Processor ??

From: <[email-masked]>
Date: Mon, 4 Mar 2002 09:07:31 +0100 (CET)

Hi David,

some hints to your questions:

>   Now I have a question about the dual processors.  What is the best
> way to utilize this extra power?  Run two jobs, each one on a separate
> processor, or look into parallel G98 code?  As I am rather inexperienced
> in UNIX, I am not at all certain even how to run two jobs at the same time.
> Any suggestions would be greatly appreciated.

Two Jobs at the same time are great, because normally you will not get an
ideal speedup of 2. You may consider starting even more jobs (perhaps 4)
at one time: If you are doing heavy I/O your processor is mostly idle and
waiting for the disk. If not, 2 are pretty good ...

>   One more thing.  I often run big jobs strung together with the --link1--
> command.  This is fine, but jobs tend to finish in the middle of the
> night.  Does anyone know how to start a new job automatically when a big
> job is finished?  I tried to add more --link1--'s to a .com file that
> was currently executing, and the whole job crashed in just a few minutes.

You should install a queueing systen like NQS or one of your Linux
distribution. Check simply out your install routine ...

Alex

---

Dr. Alexander Hofmann
Institute for Applied Chemistry Berlin-Adlershof
P.O. Box 96 11 56       Richard-Willstaetter-Str. 12

D-12474 Berlin          D-12489 Berlin

[email-masked]

Tel.: +49-30-6392-4408
Fax.: +49-30-6392-4350

http://www.aca-berlin.de

PGP-Private key:
http://wwwkeys.de.pgp.net:11371 ID:0xF39A0BC8

---

From: Laurence Cuffe <[email-masked]>
Date: Mon, 04 Mar 2002 14:54:01 +0000

Date sent:      	Fri, 01 Mar 2002 14:51:33 -0500
From:           	David Close <[email-masked]>
Subject:        	CCL:G98 Dual Processor ??
To:             	[email-masked]

>  To CCL:
>  Several weeks ago I asked for help installing G98 LINUX version on a
>Dell 530 Dual Processor workstation.  Several CCLers sent me helpful
>suggestions on how to get G98 LINUX working on this machine.  This
>is working now.  Many thanks for the help.
>processor,
This would be our preferred option, its not hard to do, for  example 
if the jobs are job1 and job2 type 
g98 job1 & (return)
g98 job2 & (return)
then both jobs will run together.  you can check this using the 
utility top
just type 
top (return)
and it will display how your procesors are doing.
 or look into parallel G98 code?  
We've run jobs using the parallel code, its not as efficient as 
running separate jobs. look up  "Amdals law" for more details.
As I am rather inexperienced
>Any suggestions would be greatly appreciated.
see above!
>job is finished? 
This is very slightly harder to do. again jobs 1 and 2
first change into the cshell by typing csh (return)
then type
g98 job1.com;g98 job2.com;& (return)
when job1 finishes job2 starts.  I would typically use this to run ten 
or twelve jobs one after another over the weekend. remember, this 
is unix, there are many different ways of doing the same thing, but 
the above is what works for us.
Hope this helps 
All the best
Laurence Cufffe 

 I tried to add more --link1--'s to a .com file that
>  Regards, Dave Close.
>-= This is automatically added to each message by mailing script =-
>[email-masked] -- To Everybody  | [email-masked] -- To Admins
>[email-masked] -- HELP CHEMISTRY or HELP SEARCH
>[email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
>Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
>
>
>
>
>

---

From: "Ole W. Saastad" <[email-masked]>
Date: Mon, 4 Mar 2002 21:13:03 +0100 (CET)

You could try to compile g98 with Intels compiler. This compiler
has support for auto parallelization. It works for some problems,
but not for all. It might work for g98, I do not have the source
for g98 here so, I have not tried. (I would if I could fine the time
to visit old frient at the Univ. of Oslo)
The auto par. works fine for a couple of seismic problems I worked on.
The Portland compiler also has this option, but it does not work well. The
Intel compiler is outstanding in this respect.

You could install threaded versions of the Blas libraries, but this
does not really speed the g98 up very much. It improves some, but not
enough time is spent in BLAS routines  to justify this move.

It would be a unseful exercise if someone could try to compile
the g98 with Intel ifc (v. 6.0 for Linux) and report the outcome.

It would also be a nice job if someone sat down and put OpenMP
comments in the g98 source code, or even better rewrote the g98
to MPI !

Ole W. Saastad
Scali A/S.

---

From: David van der Spoel <[email-masked]>
Date: Mon, 4 Mar 2002 21:38:32 +0100 (CET)

On Mon, 4 Mar 2002, Ole W. Saastad wrote:

If you compiled gaussian with portland compiler you only have to set 
%nproc=2
it has a scaling of roughly 1.4, so 70% on 2 processors depending on your
job. It works with threads.

>Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

Groeten, David.
________________________________________________________________________
Dr. David van der Spoel, 	Biomedical center, Dept. of Biochemistry
Husargatan 3, Box 576,  	75123 Uppsala, Sweden
phone:	46 18 471 4205		fax: 46 18 511 755
[email-masked]	[email-masked]   http://zorn.bmc.uu.se/~spoel
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++