Subject: compiling Mopac 7.01-4

From: Rajarshi Guha <[email-masked]>
Date: Wed, 24 Apr 2002 11:05:24 -0400

Hi,
  I'm trying to compile Mopac 7.01-4 on Linux (kernel 2.4.7-10) with g77 -I've 
tried both 2.96 and 3.0 and I get the same results:

matou1.f: In subroutine `matou1':
matou1.f:5: 
         PARAMETER (MAXDIM=MAX(MAXORB,3*NUMATM))
                           ^
Invalid declaration of or reference to symbol `max' at (^) [initially seen at 
(^)]

And a series of other errors. I'm sure somebody must have compiled it on Linux 
but I cant seem to find anything relevant to the problem in the archives. I 
also looked at the makefile and there does'nt seem to be any reference to f2c 
but all the docs say that I need f2c. I'm a little confused and ny pointers 
would be appreciated.

TIA,

- -- 
- -------------------------------------------------------------------
Rajarshi Guha                  | email: [email-masked]
417 Davey Laboratory           | web  : http:// www.jijo.cjb.net
Dept. Of Chemistry             | ICQ  : 123242928
Pennsylvania State University  | AIM  : LoverOfPanda
- -------------------------------------------------------------------
GPG Fingerprint: DCCB 4D1A 5A8B 2F5A B5F6  1F9E CDC4 5574 9017 AF2A 
Public Key     : http://pgp.mit.edu/
- -------------------------------------------------------------------
Gravity brings me down.

---

From: Rick Venable <[email-masked]>
Date: Wed, 24 Apr 2002 13:23:14 -0400

On Wed, 24 Apr 2002, Rajarshi Guha wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hi,

For f2c, Fortran front-end is often a cover script named 'fort77'; look
for that in the Makefile.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable           29/500
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905   [email-masked]
ALT email:  [email-masked]
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=