Subject: Re: CCL:CHELP sources.

From: "Dr. Peter Bladon" <[email-masked]>
Date: Tue, 21 May 2002 14:57:19 +0100

I wonder if this is not a case of stuff being downloaded in the wrong
format (windows versus unix).

I have just tried downloading some files from the ccl archives.

(1) I established an ftp connection (not http) by doing: 
ftp www.ccl.net    (logiing in as anonymous in the usual way)

(2)then:
cd pub/chemistry/coftware/SOURCES/FORTRAN/chelpg

(3) Then:
get chelpgunix.f

The file which was download in "binary" mode was readable on my IRIX
machine

I have just done the same on a Windows machine but I switched to "ASCII"
mode
instead of "bin" mode before downloading the file.  
Again the file was readable and had the correct format

Significantly, the windows file was longer  (208766 bytes) than the
file on the Unix machine (206220 bytes) the extra length being due to
the
extra "carriage returns" (ASCII code 13) needed by DOS/windows systems.

It is relatively easy to reformat between the two systems provided you 
have access to a Unix machine using the utilities to_unix and to_dos.
But I do not know how to do it on a Windows machine???

Hope this helps

Peter Bladon

"Rafael R. Pappalardo" wrote:
> 
> On Mon, 20 May 2002, Jim Kress wrote:
> 
> > Why don't you ask the author?  Follow this link:
> >
> > http://www.brynmawr.edu/chemistry/mfrancl.html
> >
> > Jim
> >
> 
> Sorry, I forgot to mention that I sent mails to both of
> them without success.
> 
> Rafael
> >
> > ----- Original Message -----
> > From: "Rafael R. Pappalardo" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Monday, May 20, 2002 10:55 AM
> > Subject: CCL:CHELP sources.
> >
> >
> > > Dear all,
> > >
> > > I am trying to implement the CHELP method in some ab initio code.
> > > I have downloaded the sources from
> > >
> > > http://www.ccl.net/cca/software/SOURCES/FORTRAN/chelpg/new/
> > >
> > > directory. Surprisingly the files have lost the fortran format.
> > > The lines begin at column 1. Some continuation lines are merged
> > > together, etc.
> > >
> > > The gopher address mentioned does not work anymore. QCPE list the
> > > program as not available.
> > >
> > > Does anybody knows where to get it? It will be wonderfull if it is a
> > > version including latest recommendations from Profs. Francl and Chirlian
> > > (RCC vol 14).
> > >
> > > Thanks,
> > >
> > > --
> > > Dr. Rafael R. Pappalardo
> > > Dept. Quimica Fisica, Fac. de Quimica, Univ. de Sevilla. 41012-Sevilla
> > (Spain)
> > > e-mail: [email-masked]
> > >
> > >
> > > [email-masked] -- To Everybody  | [email-masked] -- To
> > Admins
> > > [email-masked] -- archive search    |    Gopher: gopher.ccl.net
> > 70
> > > Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
> > [email-masked]
> > >
> > >
> > >
> > >
> > >
> >
> 
> --
> Dr. Rafael R. Pappalardo
> Dept. Quimica Fisica, Fac. de Quimica, Univ. de Sevilla. 41012-Sevilla (Spain)
> e-mail: [email-masked]
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

---

From: "Rafael R. Pappalardo" <[email-masked]>
Date: Tue, 21 May 2002 16:12:58 +0200 (CEST)

> But I do not know how to do it on a Windows machine???

Dear Peter,
the problem is not with files in the chelpg directory but with the files
in the new directory. They seem to have been sent by e-mail and I
suspect they got corrupted. Could you please verify if you can get working
Fortran files from the new directory?

Best regards,

Rafael