Subject: movie of docking

From: "Pavel A. Petukhov" <[email-masked]>
Date: Thu, 23 May 2002 10:56:31 -0400

Is there any way to visualize the docking trajectory of
a ligand to the binding site starting from a distance of
about 10 ang? The idea is to show how the ligand moves 
toward the binding site, how it adjusts its orientation when
bumps on other atoms, and how it finally sticks to the 
binding site.

Pavel A. Petukhov
Drug Discovery Group
Georgetown University Medical Center
New Research Building EP15
3900 Reservoir Road NW
Washington, DC 20007-2197
day-phone: 202-687-2368
fax: 202-687-0738
Email: [email-masked]

---

From: "DeLano, Warren" <[email-masked]>
Date: Thu, 23 May 2002 17:24:38 -0700

PyMOL can do this.  http://www.pymol.org

Basic idea:  

1. load the ligand and protein as separate objects

   load prot.pdb
   load lig.pdb

2. define a movie of a certain length 

   mset 1 x10

  (here, a 10 frame example, but you could define 100's or 1000's)

3. in the first frame of the movie, displace the ligand from the active site

   mdo 1: reset object=lig; translate [9,0,0],object=lig

  (9 A displacement, along X-axis...)

4. in the remaining 9 frames of the movie, move the ligand back incrementally.

   mdo 2: translate [-1,0,0],object=lig
   mdo 3: translate [-1,0,0],object=lig
   mdo 4: translate [-1,0,0],object=lig
   mdo 5: translate [-1,0,0],object=lig
   mdo 6: translate [-1,0,0],object=lig
   mdo 7: translate [-1,0,0],object=lig
   mdo 8: translate [-1,0,0],object=lig
   mdo 9: translate [-1,0,0],object=lig

Now you can view the movie in real time (hit play), write it out as a series of ray-traced frames with lighting and shadows, experiment with various representations, and so on.   With more work, you could use more frames (more smooth), include rotations, use the sculpting engine to simulate VDW collisions, or write the whole thing as a Python program, instead of merely a PyMOL script.  

Alternatively, you could create the trajectory using an MD/Mechanics package and just read the frames into PyMOL for viewing and rendering.

Cheers,
Warren

PS. PyMOL momentum continues to build!  Several large pharma and biotech companies have now lent their support to this unrestricted open-source viewer, builder, and animation tool.  Please consider participating if you would like to nuture a solid alternative to the closed-source commercial offerings for desktop visualization : ).

--
mailto:[email-masked]
Warren L. DeLano, Ph.D.

> -----Original Message-----
> From: Pavel A. Petukhov [mailto:[email-masked]]
> Sent: Thursday, May 23, 2002 7:57 AM
> To: [email-masked]
> Subject: CCL:movie of docking
> 
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | 
> [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: 
> gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | 
> Jan: [email-masked]
> 
> 
> 
> 
> 
>