Subject: Re: CCL:diffusion coefficient from mean square displacement

From: Kenneth Geisshirt <[email-masked]>
Date: 23 May 2002 09:21:59 +0200

On Wed, 2002-05-22 at 21:06, Hannes Loeffler wrote:

> But what does "long time" mean? I observe that the MSD curve becomes nearly
> linear after a few pico second but after some pico seconds later the line starts
> to rise again with an obviously larger slope.  Does this tell me anything about
> the quality of the potential used?  Should I be concerned about the "non-linear"
> MSD curve?

You don't explain how you compute the displacement and in what geometry
and boundary conditions you're working. With periodic boundary
conditions you have to take that into account i.e., when a particle
moves out of the simulation box (and comes back on the other side),
remember that the displacement must be added the box length.

Estimating the slope will give you the covariance matrix (see e.g. GNU
Scientific Library <http://sources.redhat.com/gsl/>. Using that matrix
you have a measure of the error bar and is the error bar too large, you
were impatient ;-).

Kneth

-- 
Kenneth Geisshirt, M.Sc., Ph.D.         http://kenneth.geisshirt.dk
Grøndals Parkvej 2A, 3. sal                    [email-masked]
DK-2720 Vanløse                                     +45 38 87 78 38

---

From: Richard Gillilan <[email-masked]>
Date: Thu, 23 May 2002 08:14:15 -0400

Hannes Loeffler wrote:
I assume you are using periodic boundary conditions
for the bulk liquid. Make sure you are treating 
periodic boundary conditions correctly in the calculation
of the MSD. 

Richard Gillilan
MacCHESS Cornell

> 
> Hello,
> 
> I'm currently trying to obtain the diffusion coefficient from the mean square
> displacement (as a test case I simulated pure water). The diffusion coefficient
> may than be derived from the long time behavior of the MSD curve (slope).
> 
> Hannes.
> Hannes Loeffler | tel: +43-(0)512-507-5166 | fax: +43-(0)512-507-2714
> http://www-c724.uibk.ac.at/staff/loeffler/ | mailto:[email-masked]
> Institute for General, Inorganic and Theoretical Chemistry
> University of Innsbruck, Austria
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]