Subject: anyone tell me how to build g98 A11 with ifc 6.0

From: atsutoshi konoo <[email-masked]>
Date: Wed, 17 Jul 2002 21:55:48 +0900

hi CCLers

I am  trouble about compiling Gaussian98 Rev A11 with Intel Fortran
Compiler.
Please tell me how to build it with properly.
It's first compilation g98 with ifc for me.

I am using ifc(intel fortran compiler)6.0 evaluate version,and 
it works good.

for building  with ifc,I modified some part of bsd/i386.make like as following.

RUNF77 = ifc
F2CLIB =
LIBS = -lPEPCF90
UNROLL = -unroll
VECTOR = -vec
TWOH =
PC64 =  -pc64
 
and I got build.logs  like as below

-------bldg98.log-------------------------
     .
     .
     .
     .
rm ./as8zmYLF.as

rm ./argt9fLkg.arg

rm -f ml0.f ml0.c
make[1]: Leaving directory `/home/g98'
ifc   -O2 -tp p6  -unroll -vec -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -W0 -v
 -o g98 ml0.o   util.so -lPEPCF90
ifc: warning: -vec is default; use -x and -ax to configure vectorization
ld  \
    /usr/lib/crt1.o \
    /usr/lib/crti.o \
    /opt/intel/compiler60/ia32/lib/crtxi.o \
    -dynamic-linker \
    /lib/ld-linux.so.2 \
    -o \
    g98 \
    ml0.o \
    util.so \
    -lPEPCF90 \
    -Qy \
    /opt/intel/compiler60/ia32/lib/icrt.link \
    -u \
    ___pseudo_link \
    -L/opt/intel/compiler60/ia32/lib \
    -L/usr/lib \
    -Bstatic \
    -lintrins \
    -lIEPCF90 \
    -lF90 \
    -lintrins \
    -limf \
    -Bdynamic \
    -lm \
    -Bstatic \
    -lirc \
    -Bdynamic \
    -lcxa \
    -Bstatic \
    -lcprts \
    -lunwind \
    -Bdynamic \
    -lcxa \
    -Bdynamic \
    -lc \
    /opt/intel/compiler60/ia32/lib/crtxn.o \
    /usr/lib/crtn.o

util.so: undefined reference to `wait_'
util.so: undefined reference to `fork_'
make: *** [g98] Error 1
------------------------------------------

comparing to pgf77 building logs,I found wait_ and fork_ 
is linked pgf77 libs.

if when one use ifc,which libraries must be required?

or,Does anyone know website which has informations about g98 built with ifc?
  
finally,I am sorry for  my silly question.

regards. 

#################################
KGT Inc      systerm service dept
cluster tech group
Atsutoshi Konoo
+81-03-3225-0747                 
[email-masked]             
################################# 

--
atsutoshi konoo  [email-masked]

---

From: Christoph van Wüllen <[email-masked]>
Date: Wed, 17 Jul 2002 16:05:38 +0200

>It's first compilation g98 with ifc for me.
if wait_ and fork_ are not included in the ifc libs (Try -Vaxlib), then it
is trivial to write a "wrapper" in C (its a one-liner). Wait and Fork are
simply FORTRAN-callable versions of the well-known wait() and fork() 
system calls (look at rs6kdum.F and mdutil.F for hints).

Probably you can use dummies for the first try. I guess that fork() and wait()
are only used in parallel calculations.

+---------------------------------+----------------------------------+
| Prof. Christoph van Wüllen      | Tele-Phone (+49) (0)30 314 27870 |
| Technische Universität Sekr. C3 | Tele-Fax   (+49) (0)30 314 23727 |
| Straße des 17. Juni 135         | eMail                            |
| D-10623 Berlin, Germany         | [email-masked] |
+---------------------------------+----------------------------------+