Subject: GAMESS: pgi compilation

From: FyD <[email-masked]>
Date: Thu, 14 Nov 2002 10:08:10 +0100 (CET)

Dear All, 
 
I just finished to compile the last GAMESS version on Debian 2.2 with either 
g77 or pgf77. (For pgf77 we had to modify the ddisoc.c file as it is described 
in the source file) 
 
If I run the 32 tests with the binary obtained from g77, all finished 
"gracefully". On the contrary, with the binary built with pgf77, the input 
number 19 stays blocked... See below: 
 
nautilus1:~/link/gamess> tail  exam19.log 
 2-EL. CONTRIBUTION(CM-1)         0.0000   -49.4168I 
 < 1-1A1   (MS= 0.0)|HSO| 1-3A2   (MS= 1.0)> =     0.0000     0.0000I    [Z] 
 1-EL. CONTRIBUTION(CM-1)         0.0000     0.0000I 
 2-EL. CONTRIBUTION(CM-1)         0.0000     0.0000I 
 < 1-1A1   (MS= 0.0)|HSO| 1-3A2   (MS=-1.0)> =     0.0000     0.0000I    [P] 
 1-EL. CONTRIBUTION(CM-1)         0.0000     0.0000I 
 2-EL. CONTRIBUTION(CM-1)         0.0000     0.0000I 
 
 STEP CPU TIME =     0.00 TOTAL CPU TIME =        0.1 (    0.0 MIN) 
 TOTAL WALL CLOCK TIME=        0.1 SECONDS, CPU UTILIZATION IS 107.69% 
 
Is it a known problem ?  
 
Thanks, Kind regards, Francois

---

From: Matthias Mann <[email-masked]>
Date: Thu, 14 Nov 2002 10:22:53 +0100

Hallo Francois,

some weeks ago I wrote to the Gamess list (maybe this helps):

...
Furthermore, there was once more the exam19 problem because
of optimizing the code with -O2 in zheev, as observed earlier
(see http://www.chm.tu-dresden.de/edv/gamess99/comp.html ).

So at the end the according lines in "comp" for pgf77 (ver. 3.2)
looks like:

   if ($TARGET == linux-pc) then
      setenv PATH $PATH\:/home/apps/pgi/linux86/bin
      setenv PGI /home/apps/pgi
      if (($MODULE == qfmm) || ($MODULE == solib) || ($MODULE == zheev)) then
          mv $MODULE.f $MODULE.junk
          sed -e s/DREAL/DBLE/g $MODULE.junk > $MODULE.f
          rm -f $MODULE.junk
      endif
 
      set OPT = '-O2 -Msecond_underscore'
      if ($MODULE == zheev) set OPT = '-O0 -Msecond_underscore'

      set echo
      pgf77 -c $OPT $MODULE.f
      unset echo
   endif

On Thursday 14 November 2002 10:08, you wrote:
> Dear All,
>
> I just finished to compile the last GAMESS version on Debian 2.2 with
> either g77 or pgf77. (For pgf77 we had to modify the ddisoc.c file as it is
> described in the source file)
>
>  < 1-1A1   (MS= 0.0)|HSO| 1-3A2   (MS= 1.0)> =     0.0000     0.0000I   
> [Z] 1-EL. CONTRIBUTION(CM-1)         0.0000     0.0000I
>  < 1-1A1   (MS= 0.0)|HSO| 1-3A2   (MS=-1.0)> =     0.0000     0.0000I   
> [P] 1-EL. CONTRIBUTION(CM-1)         0.0000     0.0000I
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
> [email-masked]

-- 
Dr. Matthias Mann 
Fachrichtung Chemie, TU Dresden, D-01062 Dresden
Tel./Fax: +49 (351) 463-34286
Email: [email-masked]