Subject: Re: CCL:code to solve Poisson-Boltzmann

From: "Nathan A. Baker" <[email-masked]>
Date: Thu, 9 Jan 2003 07:02:39 -0600

Hi All --

APBS uses Mike Holst's PMG/MG multigrid software package for numerical
solution of the PBE.  Additionally, Mike's original software pacakge
is available from his web site
(http://scicomp.ucsd.edu/~mholst/codes/pmg/index.html).

Have fun!

-- Nathan

Wibke Sudholt <[email-masked]> (12-26-2002 17:58:44-0800):
>Hello,
>
>perhaps you may take a look at APBS:
>
>http://agave.wustl.edu/apbs/
>
>I hope this helps,
>
>Wibke Sudholt
>University of California, San Diego
>[email-masked]
>
>
>-----Original Message-----
>From: Computational Chemistry List [mailto:[email-masked]]On
>Behalf Of Damian A Scherlis Perel
>Sent: Thursday, December 26, 2002 4:50 PM
>To: [email-masked]
>Subject: CCL:code to solve Poisson-Boltzmann
>
>
>
> Dear all,
>
> I am interested in a subroutine or package to solve
> numerically in a grid elliptic partial differential
> equations (in particular the Poisson-Boltzmann equation).
> I have been trying with the multigrid code of Michael
> Holst released in 1995, but it shows serious inaccuracies
> in R3 for the kind of trial potentials I used to test it.
> Is anyone aware of some other code suitable for this?
>
> Many thanks, and happy holidays,
>
> ------------------------
> Damian Scherlis
> Department of Materials Science & Engineering
> Massachusetts Institute of Technology
> [email-masked]
> 617 253 6026
>
>
>
>
>
>
>
>
>
>-= This is automatically added to each message by mailing script =-
>[email-masked] -- To Everybody  | [email-masked] -- To Admins
>Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
>
>
>
>
End of message from Wibke Sudholt.

-- 
Nathan A. Baker, Assistant Professor
Washington University in St. Louis School of Medicine
Dept. of Biochemistry and Molecular Biophysics
Center for Computational Biology
700 S. Euclid Ave., Campus Box 8036, St. Louis, MO 63110
Phone:  (314) 362-2040, Fax:  (314) 362-0234
URL:  http://www.biochem.wustl.edu/~baker

---

From: Michael Holst <[email-masked]>
Date: Thu, 9 Jan 2003 09:17:14 -0800

Hi Nathan and all,

Thanks for forwarding this email.  The elliptic solver PMG/MG that
is used by APBS for the low-level solve of the Poisson-Boltzmann 
equation definitely produces accurate solutions to a very
general class of 3D scalar nonlinear elliptic problems.  It has
been used for almost ten years by a number of independent groups,
and has been thoroughly tested on a large range of model problems
with various features.

Due to the fairly complex PDE interface that I gave PMG/MG for
efficiency, it is pretty easy to make a mistake in specifying
the PDE; I predict that this is what you are running into, if the
PMG/MG numerical solution does not agree with a known analytical solution.

If you are specifically interested in solving the Poisson-Boltzmann
equation, then you should definitely use APBS rather than PMG/MG
directly; an enormous amount of work was put into APBS to model the
electrostatics problem correctly using the Poisson-Boltzmann approach.
I don't think you want to try to recreate this structure independently;
there are a lot of subtle difficulties with the Poisson-Boltzmann equation.
PMG/MG then does the low-level solution of the elliptic systems, only after
APBS has done all of the subtle mathematical modeling correctly.

Best regards, -mike
-- 
  Michael Holst               TELE:  (858) 534-4899
  Associate Professor         FAX:   (858) 534-5273
  Department of Mathematics   EMAIL: [email-masked]
  UC San Diego, AP&M 5739     WEB:   http://scicomp.ucsd.edu/~mholst
  La Jolla, CA 92093 USA      PGP:   http://scicomp.ucsd.edu/~mholst/pgp.html
  * Please avoid sending me Word or PowerPoint attachments.
    See http://www.fsf.org/philosophy/no-word-attachments.html
--

>End of message from Wibke Sudholt.
End of message from Nathan A. Baker.