Subject: how to deal with box in CHARMM?

From: Jinzhi Tan <[email-masked]>
Date: Thu, 17 Apr 2003 10:52:44 +0800

Dear Sir:
I generate a large box containing 15000 waters. When I try to put the protein into the box, it always occur "string too small" error and stop. Maybe the number of water are too many. I don't know how to split the box into several segments? or split the box into small box? Thank you very much!

Best wishes,

Jinzhi Tan
2003-4-17

*************************************
Jinzhi Tan     Ph.D. student
Chinese Academy of Sciences
Shanghai 200031, China
Phone :086-21-64311833-507
Fax   :086-21-64318401
E-mail:[email-masked] 
       [email-masked]
*************************************

---

From: Rick Venable <[email-masked]>
Date: Thu, 17 Apr 2003 11:11:21 -0400

On Thu, 17 Apr 2003, Jinzhi Tan wrote:

>  Dear Sir:
> I generate a large box containing 15000 waters. When I try to put the
> protein into the box, it always occur "string too small" error and
> stop. Maybe the number of water are too many. I don't know how to
> split the box into several segments? or split the box into small box?
> Thank you very much!

At present, a CHARMM segment cannot contain more than 9999 residues; you
*must* split your water into at least 2 segments.  You will also
probably need to use a CHARMM version compiled with LARGE or XXLARGE
size specification for a system with this many atoms.

Note that a fairly new developmental version of CHARMM undergoing
preliminary tests now allows for (10**8 - 1) residues per segment.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable           29/500
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905   [email-masked]
ALT email:  [email-masked]
-------------------------------------
"Don't blame me, I voted for Kang."
                         Homer
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=