Subject: CCL:re:shifting coordinates with CHARMM

From: Jerry Ebalunode <jebalunode=at=adrik.bchs.uh.edu>
Date: Thu, 22 May 2003 07:43:26 -0700

You can recenter the coordinates to align with the axis by adding this charmm 
command lines before the instructions for writing out the the translated 
molecule to an output file . Hope this helps.

coor orient sele all end
define origin select all end
coordinate statistics
coor translate xdirection -?XAVE ydirection -?YAVE zdirection -?ZAVE

On Wednesday 21 May 2003 05:29 pm, you wrote:
> Hi,
>
> is it possible to re-center coordinates with CHARMM?  Some viewing programs
> are not aware of PBCs and during a simulation the system of interest may
> diffuse to the edges of the box.  It might be useful, therefore, to shift
> an atom (or maybe an arbritary point in space) to the center of the box.
>
> TIA,
> Hannes.
>
> -= This is automatically added to each message by mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject:
> line and send your message to:  CHEMISTRY=at=ccl.net
>
> Send your subscription/unsubscription requests to:
> CHEMISTRY-REQUEST=at=ccl.net HOME Page: http://www.ccl.net   | Jobs Page:
> http://www.ccl.net/jobs
>
> If your mail is bouncing from CCL.NET domain send it to the maintainer:
> Jan Labanowski,  jkl=at=ccl.net (read about it on CCL Home Page)
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

-- 
Jerry Ebalunode
Graduate Research Assistant
RM 402F Houston Science Center
Dept. of Biology and Biochemistry
University of Houston.
4800 Calhoun Road
Houston, TX 77204

---

From: Rick Venable <rvenable[at]pollux.cber.nih.gov>
Date: Thu, 22 May 2003 11:09:39 -0400

That's not quite correct-- a solvated box would be rotated to be align a
diagonal with the X axis by the COOR ORIENT command in the reply below;
you must use NOROT to supress rotation.  An image update is also needed
to re-pack the solvent (and possibly ions) once the macromolecule has
been moved to the Cartesian origin.  To move the solute and repack the
solvent, etc., images must be present (IMAGE or CRYSTAL) and image
centering setup for solvent etc. via IMAGE BYRES; then

COOR ORIENT NOROT SELE SEGID A END ! move segid A to origin
UPDATE IMGFRQ 1                    ! force an image update

On Thu, 22 May 2003, Jerry Ebalunode wrote:
> You can recenter the coordinates to align with the axis by adding this
> charmm command lines before the instructions for writing out the the
> translated molecule to an output file . Hope this helps.
>
>
> coor orient sele all end

> On Wednesday 21 May 2003 05:29 pm, Hannes Loeffler wrote:
> > is it possible to re-center coordinates with CHARMM?  Some viewing
> > programs are not aware of PBCs and during a simulation the system of
> > interest may diffuse to the edges of the box.  It might be useful,
> > therefore, to shift an atom (or maybe an arbritary point in space)
> > to the center of the box.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable           29/500
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905   Rick_Venable[at]nih.gov
ALT email:  rvenable[at]speakeasy.org
-------------------------------------
"Don't blame me, I voted for Kang."
                         Homer
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=