Subject: Re: CCL:Ewald in CHARMM

From: Ben Swerts <ben.swerts!at!ua.ac.be>
Date: Mon, 7 Jul 2003 08:11:05 +0200

Hi Niharendu,

This message means CHARMM needs more memory and your architecture cannot 
provide more memory at runtime. You'll have to recompile CHARMM with a larger 
heap-size. Check out the file heap.fcm and change the parameter HEAPDM in the 
correct place for your architecture.

	Ben

On Saturday 05 July 2003 00:24, you wrote:
> Hi all,
> I was initially running with following crystal keywords:
>
>  Crystal Define Cubic 24.850 24.850 24.850  90.0 90.0 90.0
>  Crystal Build noperations 0
>
>  and energy keywords :
>
> ENERGY ATOM ELEC EWALD KAPPA 0.21  KMAX 4 KSQMAX 27 -
>            CUTNB 10.0  CUTIM 10.0 CTOFNB 9.5  VDW SHIFT
>
>  it was running fine.
>
>
>  Now I have changed the energy section to the following:
>
>  ENERGY ATOM ELEC EWALD KAPPA 0.21  KMAX 4 KSQMAX 27 -
>            CUTNB 12.0  CUTIM 12.0 CTOFNB 10  VDW SHIFT
>
>  and it is not running. (I have only changed cutnb and ctofnb, crystal
>  section being the same).
>
> FOR MORE DETAILS I am appending below the output error message:
[snip]
>
>       ***** LEVEL -4 WARNING FROM <VEHEAP> *****
>       ***** CANNOT EXPAND HEAP ON THIS MACHINE
>       ******************************************
>       BOMLEV (  0) IS REACHED - TERMINATING. WRNLEV IS  5
>  Execution terminated due to the detection of a fatal error.
>
[snip]

---

From: Michael Crowley <crowley:at:scripps.edu>
Date: Wed, 9 Jul 2003 14:13:03 -0700 (PDT)

Concerning the heap expand error message:

You have increased the cutoff so most likely the message is
not coming from ewald, but from the nonbond list generator.
The list will be considerably bigger, and it is in HEAP memory.
Normally, the heap will be reallocated during the run (on most
machines) to accomodate the need.

Your message says that heap cannot be increased on the machine.
It is either because it cannot reallocate (there is no viable
memalloc function) or that there is not enough memory on your
machine to accomodate the need.

Recompiling with a larger heap will help the first cause.
The second cause will not be helped by recompiling.

What architecture are you running on?
Mike

-----------------------------------------------------------------
Physical mail:   Dr. Michael F. Crowley
                 Department of Molecular Biology, TPC6
                 The Scripps Research Institute
                 10550 North Torrey Pines Road
                 La Jolla, California 92037

Electronic mail: crowley:at:scripps.edu
Telephone:         858/784-9290
Fax:               858/784-8688
-----------------------------------------------------------------

On Mon, 7 Jul 2003, Ben Swerts wrote:

> -= This is automatically added to each message by mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
> and send your message to:  CHEMISTRY:at:ccl.net
>
> Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST:at:ccl.net
> HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs
>
> If your mail is bouncing from CCL.NET domain send it to the maintainer:
> Jan Labanowski,  jkl:at:ccl.net (read about it on CCL Home Page)
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>
>
>
>
>
>
>