Subject: Re: CCL:EWALD PME problem

From: Rick Venable <rvenable_at_pollux.cber.nih.gov>
Date: Thu, 31 Jul 2003 11:58:15 -0400

On Wed, 30 Jul 2003, Michael Chen wrote:
>    Sorry to post here again for some pain in the neck.    Everytime, when I
> used the command line in a multiple- processor run like this:
>
> NBONDED -
> EWALD PMEwald KAPPa 0.55 FFTX 81 FFTY 81 FFTZ 81 -
> ORDe 6 cutnb 10 ctofnb 8 ctonnb 7 cutim 10 -
> inbfrq -1 imgfrq -1 vdw vshift wmin 1.0
>
>     CHARMM just stopped right here, which never happened in a
> singular-processor run. Thus, in parallel mode, I had no way in using
> PME method, but using the commnad like:
>
> energy group   switch cdiel -
>        vgroup  vswitch      -
>        ctonnb 8.0 ctofnb 11.0 cutnb 12.0 cutim 12.0
>
>     The machine I ran CHARMM on was SUN Solaris system with 30
> processors. Could this be the hardware thing?

The values used for FFTX, FFTY, and FFTZ have some restrictions on them;
the first is that the integers must have only 2, 3, and 5 as prime
factors.

Another restriction, which is probably causing your problem, is that the
integers used for FFTX etc. must also be evenly divisable by the number
of processors.  You should probably change FFTX etc. to e.g. 80 (for 8
or 16 processors) or to 90 (30 processors).

Also, your values for CTOFNB and KAPPA are significantly different from
the recommend ones, so if you haven't carefully evaluated the
consequences for the relative force errors, you may wish to reconsider
these choices.  For more info on evaluating force errors, see the
Appendices in

Effect of Electrostatic Force Truncation on Interfacial and Transport
Properties of Water
Scott E. Feller, Richard W. Pastor, Atipat Rojnuckarin, Stephen Bogusz,
and Bernard R. Brooks
J. Phys. Chem. 1996, vol 100, pp. 17011-17020

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable           29/500
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905   Rick_Venable:at:nih.gov
ALT email:  rvenable:at:speakeasy.org
-------------------------------------
"Don't blame me, I voted for Kang."
                         Homer
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=

---

From: Michael Crowley <crowley{at}scripps.edu>
Date: Fri, 1 Aug 2003 16:36:50 -0700 (PDT)

Rick and Michael,
I will check, but I am fairly sure that the
fft dims do not need to be a multiple of number of processors,
at least that was my intention.
2,3,5 prime factors is definitely essential

There is one more catch: If you are using RCFFT (real-to-comlex)
then the x-fftdim must be even. Check you output for a lind
specifying whether it is real-to-complex, or check your pref.dat,
or have a line in your script : pref
and check if RCFFT is there. If not, then only the 2,3,5 restriction
applies.

Sincerely,
Mike

-----------------------------------------------------------------
Physical mail:   Dr. Michael F. Crowley
                 Department of Molecular Biology, TPC6
                 The Scripps Research Institute
                 10550 North Torrey Pines Road
                 La Jolla, California 92037

Electronic mail: crowley{at}scripps.edu
Telephone:         858/784-9290
Fax:               858/784-8688
-----------------------------------------------------------------