Subject: Re: CCL:molecule substructure searching algorithms

From: Geoff Hutchison <hutchisn{at}chem.northwestern.edu>
Date: Wed, 17 Sep 2003 14:10:21 -0500

> The first problem harassing me is how to efficiently recognize and 
> sign a specific
> functional group in a molecule.
>
> Is here anyone who could tell me where can I find some open source 
> code for
> molecule substructure searching algorithms, or any free program 
> dealing with it?

There are several open source implementations of Daylight SMARTS.

OpenBabel (C++) http://openbabel.sf.net/
JOELib (Java)   http://joelib.sf.net/

It's quite easy to write SMARTS patterns for matching functional groups.
http://www.daylight.com/dayhtml/doc/theory/theory.smarts.html

-Geoff

--
-Geoff Hutchison		<hutchisn{at}chem.northwestern.edu>
Ratner/Marks Groups	(847) 491-3295
Northwestern Chemistry	http://www.chem.northwestern.edu/

---

From: "E.L. Willighagen (Egon)" <egonw~at~sci.kun.nl>
Date: Wed, 17 Sep 2003 22:07:14 +0200

On Wednesday 17 September 2003 21:10, Geoff Hutchison wrote:
> > sign a specific functional group in a molecule.
> >
> > code for molecule substructure searching algorithms, or any free program
> > dealing with it?

CDK (Java, http://cdk.sf.net/) does substructure searching.

Egon

-- 
PhD Molecular Representation in Chemometrics
Laboratory of Analytical Chemistry
http://www-cac.sci.kun.nl/people/egonw.html