Subject: CMLRSS: A Peer to Peer Chemical Information System

From: "Rzepa, Henry" <h.rzepa=at=imperial.ac.uk>
Date: Thu, 11 Mar 2004 15:41:54 +0000

As part of a session on "Research Collaboratories, Virtual laboratories and  Grid  Computing" at the
forthcoming ACS meeting (http://oasys2.confex.com/acs/227nm/techprogram/ )
we are presenting on  "Semantic Grid computing - the WorldWideMolecularMatrix"

Part of this will focus on the  theme of  RSS which  I posted about last year. We
have now developed a chemical component to this, now christened CMLRSS, and it is
the purpose of this email to invite people if they wish, to join in to this "virtual laboratory",
and hence "participate" in the ACS session.

The procedure is as follows

a) For an introduction to the concept, see eg http://www.ch.ic.ac.uk/rzepa/cmlrss_distrib/
or http://wwmm.ch.cam.ac.uk/moin/CmlRss

b)We have prepared a distribution kit available either from http://www.ch.ic.ac.uk/rzepa/cmlrss_distrib/
or from http://wwmm.ch.cam.ac.uk/moin/RssClient  We emphasize that whilst we believe this to
function correctly, it has not yet been comprehensively tested on all platforms, and some
components are still at the  "late alpha", or  "early beta" stage. Needless to say, we welcome
comments and reports of bugs!

c) You can view the existing  CMLRSS grid by installing either  Jmol (a 3D molecule viewer)
or  JChempaint (a 2D editor) as provided, along with the  CMLRSS plugin in the kit
(these are Java programs so you will have to have  Java installed). By
running this, you will open around 8 existing  RSS "Channels" and hence subscribe to chemical
feeds from these sites.  You can if you wish aggregate these feeds into one, then filter them
down by  (e.g. element).   You will notice several themes in the existing channels,
including an aggregation of the long running "Molecules of the  Month" sites, several
database sites (NMR, X-Ray, ChemStock) and the  World-Wide Molecular  Matrix.

d) You are also welcome to follow the instructions in the above distribution to
create your own  CMLRSS channel (I might add that several of the sites mentioned above
were our beta testers for this kit; it took only one or two days to get up and running).
If you do so, please let us know so that we can add you to the list (one of the many
"todo" items is to organise the addition of further channels in a better way).

I should end with the observation that as far as we know, this is the furthest that the
RSS concept has been pushed into a science field, and another step towards the
"semantic web" espoused by Sir Tim Berners-Lee.  We would of course love to hear
about your experiences with this system.

-- 

Henry Rzepa.
+44 (020) 7594 5774 (Voice); +44 (0870) 132 3747 (eFax)
 http://www.ch.ic.ac.uk/rzepa/ Dept. Chemistry, Imperial College London, SW7  2AZ, UK.

(Voracious anti-spam filter in operation for received email.
If expected reply not received, please phone/fax).

---

From: "C Anthony Lewis" <calewis(at)plymouth.ac.uk>
Date: Thu, 11 Mar 2004 18:52:38 -0000

Hello,

This looks exciting... Not that really I understand what's going on!

However, when I tried to run the RssClient Windows "Without Java VM"
self extractor (from http://wwmm.ch.cam.ac.uk/moin/RssClient), I
obtained an InstallAnywhere error saying the trial period had expired.

Is this something I'm doing wrong?

Anthony Lewis

C. Anthony Lewis
Petroleum & Environmental Geochemistry Group,
School of Earth, Ocean and Environmental Sciences,
University of Plymouth,
Plymouth, Devon PL4 8AA, U.K.

tel: +44 (0)1752 233000 ext. 2988
FAX: +44 (0)1752 233035
e-mail: calewis(at)plymouth.ac.uk

-----Original Message-----
From: chemweb-bounces(at)imperial.ac.uk
[mailto:chemweb-bounces(at)imperial.ac.uk] On Behalf Of Rzepa, Henry
Sent: 11 March 2004 15:42
To: chemweb(at)imperial.ac.uk; chemistry(at)ccl.net
Subject: [chemweb] CMLRSS: A Peer to Peer Chemical Information System

As part of a session on "Research Collaboratories, Virtual laboratories
and  Grid  Computing" at the forthcoming ACS meeting
(http://oasys2.confex.com/acs/227nm/techprogram/ ) we are presenting on
"Semantic Grid computing - the WorldWideMolecularMatrix"

Part of this will focus on the  theme of  RSS which  I posted about last
year. We have now developed a chemical component to this, now christened
CMLRSS, and it is the purpose of this email to invite people if they
wish, to join in to this "virtual laboratory", and hence "participate"
in the ACS session.

a) For an introduction to the concept, see eg
http://www.ch.ic.ac.uk/rzepa/cmlrss_distrib/
or http://wwmm.ch.cam.ac.uk/moin/CmlRss

b)We have prepared a distribution kit available either from
http://www.ch.ic.ac.uk/rzepa/cmlrss_distrib/
or from http://wwmm.ch.cam.ac.uk/moin/RssClient  We emphasize that
whilst we believe this to function correctly, it has not yet been
comprehensively tested on all platforms, and some components are still
at the  "late alpha", or  "early beta" stage. Needless to say, we
welcome comments and reports of bugs!

c) You can view the existing  CMLRSS grid by installing either  Jmol (a
3D molecule viewer) or  JChempaint (a 2D editor) as provided, along with
the  CMLRSS plugin in the kit (these are Java programs so you will have
to have  Java installed). By running this, you will open around 8
existing  RSS "Channels" and hence subscribe to chemical feeds from
these sites.  You can if you wish aggregate these feeds into one, then
filter them
down by  (e.g. element).   You will notice several themes in the
existing channels,
including an aggregation of the long running "Molecules of the  Month"
sites, several database sites (NMR, X-Ray, ChemStock) and the
World-Wide Molecular  Matrix.

d) You are also welcome to follow the instructions in the above
distribution to create your own  CMLRSS channel (I might add that
several of the sites mentioned above were our beta testers for this kit;
it took only one or two days to get up and running). If you do so,
please let us know so that we can add you to the list (one of the many
"todo" items is to organise the addition of further channels in a better
way).

I should end with the observation that as far as we know, this is the
furthest that the RSS concept has been pushed into a science field, and
another step towards the "semantic web" espoused by Sir Tim Berners-Lee.
We would of course love to hear about your experiences with this system.

-- 

Henry Rzepa.
+44 (020) 7594 5774 (Voice); +44 (0870) 132 3747 (eFax)
 http://www.ch.ic.ac.uk/rzepa/ Dept. Chemistry, Imperial College London,
SW7  2AZ, UK.

_______________________________________________
chemweb mailing list
chemweb(at)imperial.ac.uk http://mailman.ic.ac.uk/mailman/listinfo/chemweb
List coordinator, Henry Rzepa (mailto:rzepa(at)ic.ac.uk)