Subject: Re: CCL:Question regarding Mac G5 performance

From: Mengjuei Hsieh <mengjueh~at~uci.edu>
Date: Wed, 19 May 2004 18:44:34 -0700

Hi Joe,

(a) Yes, it's possible. MPICH share memory works though it sucks. People in
the apple scitech community normally suggest LAM/MPI instead.
(b) You've better have IBM XL C/C++ and FORTRAN compiler
(c) Yes and No. XL compiler optimizes better than AltiVec Framework when it
goes to double. But AltiVec's framework helps GNU compiler a lot.

I would suggest you to check the customized quote from Apple
representatives.

For the benchmark, see
http://apple.sysbio.info/~mjhsieh/archives/000334.html

Best,
-- 
Mengjuei Hsieh, Luo group, Molecular Biology and Biochemistry, University of
California Irvine. Tel: 49562, Address: 3144 Natural Science I building,
UCI, Irvine CA 92697-3900. Group Homepage: http://rayl0.bio.uci.edu/

On 19 May 2004 12:06:49, Joe M Leonard at jle~at~world.std.com wrote:
> Folks, has anybody run QM or MD benchmarks on a dual-processor
> 2GHz G5 that they care to share?  I'm particularly interested
> in how they stack up to the newest/newer Opteron and Pentium4
> machines.  If you've worked with the newer Mac's, (a) is it
> possible to get good, useful 2x processor performance for
> double-precision code?  (b) what compilers are required to get
> (a)?  (c) is Altivec useful for double-precision code, or
> merely for int/float work?
> 
> A quick glance at apple.com suggests these machines go for about
> $3200 USD, which isn't that different from numbers gained from a
> quick glance at dell.com.  I know IBM chips were number-crunchers
> in the good old days, and I assume that's still the case now (which
> is why I'm looking to CCL for guidance :-).
> Thanks in advance!
> Joe Leonard
> jle~at~theworld.com

---

From: Rick Venable <rvenable:at:pollux.cber.nih.gov>
Date: Wed, 19 May 2004 16:13:22 -0400

On Wed, 19 May 2004, Mike McCallum wrote:
> The built-in Gigabit enet is attractive, also, as charmm and NAMD
> scale very well with gigabit, and it makes myrinet less
> price-effective (when used on any platform, wintel included, see
> http://biobos.nih.gov/apps/charmm/charmmdoc/Bench/c30b1.html for
> example).  I decided that dual G5 xserve cluster nodes with gigabit
> switches were much more cost-effective for me than any other
> processor, especially any high-bandwidth specialty comm method
> (apple's gigabit has a pretty low latency also).

Having run the CHARMM benchmarks cited above, I'd disagree that they
suggest Gigabit is a viable alternative to Myrinet for CHARMM
calculations; in fact, they suggest that Gigabit isn't much better than
100baseT, but doesn't degrade as badly for 8 processors on 4 nodes.
The performance gain is so marginal that site policy is to recommended
using only Myrinet for calculations with more than 2 processors.

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable           29/500
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905   Rick_Venable:at:nih.gov
ALT email:  rvenable:at:speakeasy.org
-------------------------------------
"Don't blame me, I voted for Kang."
                         Homer
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=