Subject: Why program in Java?

From: jle$at$TheWorld.com
Date: Fri, 4 Jun 2004 07:46:17 -0400 (EDT)

Folks, I would appreciate pointers to any article/book discussing
the pros and cons of programming in Java.  Either with regards to
other interpreted languages such as Python/Perl, or with regards
to compiled languages such as C/C++.  Truly comparative articles
would be best, although evangelical texts would suffice (i.e. I've
read some of the XP literature :-).

Thanks in advance!

Joe

---

From: Joerg Wegner <wegnerj$at$informatik.uni-tuebingen.de>
Date: Fri, 4 Jun 2004 17:34:07 +0200 (MST)

Hi,

i know only a VERY OLD summary, which was before the new JIT compiler, so
it is definitely deprecated, also things like GCJ are not part of it, but
... it's the only study i know ... and be also critical when reading it:

@ARTICLE{pre00,
  author = {L. Prechelt},
  title = {{A}n empirical comparison of {C}, {C++}, {J}ava, {P}ython,
{R}exx, and {T}cl},
  journal = {IEEE Computer},
  year = {2000},
  volume = {33},
  number = {10},
  pages = {23--29},
  groupsearch = {0},
  contents = {c, c++, java, python, tcl, perl, rexx},
  abstract = {Often heated, debates regarding different programming
languages'
	 effectiveness remain inconclusive because of scarce data and a
lack of direct
	 comparisons. The author addresses that challenge, comparatively
analyzing 80
	 implementations of the phonecode program in seven different
languages (C,
	 C++, Java, Perl, Python, Rexx, and Tcl). Further, for each
language,
	 the author analyzes several separate implementations by different
	 programmers. The comparison investigates several aspects of each
language,
	 including program length, programming effort, run-time
efficiency, memory
	 consumption, and reliability. The author uses comparisons to
present insight
	 into program language performance. For example, the study
indicates
	 that Java's memory overhead is still huge compared to C or C++,
but
	 its runtime efficiency has become quite acceptable. The scripting
	 languages, however, offer reasonable alternatives to C and C++,
even
	 for tasks that must handle fair amounts of computation and
data.},
  topics = {c, c++, java, python, tcl, perl, rexx},
}

Kind regards, Joerg

On Fri, 4 Jun 2004 jle$at$TheWorld.com wrote:

> -= This is automatically added to each message by the mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
> and send your message to:  CHEMISTRY$at$ccl.net
> 
> Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST$at$ccl.net 
> HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs 
> 
> If your mail is bouncing from CCL.NET domain send it to the maintainer:
> Jan Labanowski,  jlabanow$at$nd.edu (read about it on CCL Home Page)
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> 
> 
> 
> 
> 
> 

Dipl. Chem. Joerg K. Wegner
Center of Bioinformatics Tuebingen (ZBIT)
Department of Computer Architecture
Univ. Tuebingen, Sand 1, D-72076 Tuebingen, Germany
Phone: (+49/0) 7071 29 78970
Fax: (+49/0) 7071 29 5091
E-Mail: mailto:wegnerj$at$informatik.uni-tuebingen.de
WWW:    http://www-ra.informatik.uni-tuebingen.de
--
Never mistake motion for action.
                                    (E. Hemingway)
                         
Never mistake action for meaningful action.
                               (Hugo Kubinyi,2004)