Subject: Re: CCL:protein cross the boundary of the box in PBC

From: Wei Shi <weishi-.at.-umich.edu>
Date: Wed, 23 Jun 2004 14:09:11 -0400 (EDT)

Hi, Rick,

Thanks for your help.

All the best,

Wei Shi

On Wed, 23 Jun 2004, Rick Venable wrote:

> 	First, I'd like to suggest using the CHARMM discussion Forums at
> www.charmm.org; people from several of the development groups regularly
> read and answer posts, and the message threads are searchable.
>
> N.B.  CHARMM == academic, CHARMm == commercial
>
> 	There's an arcane feature known as image patching (IMPATCH; see
> images.doc) which allows creating a bond to an image molecule;
> historically, I believe DNA simulations were attempted using this.
> There are a number of restrictions and requirements:
>
> [1] IMAGE facility only, not CRYSTal
> [2] must create the image patch
> [3] must account for ANGLE, DIHEDRAL terms in the patch
> [4] must prepare image transformation list
> [5] cannot use Ewald or CPT methods (both require CRYSTal)
>
>
> On Tue, 22 Jun 2004, Wei Shi wrote:
> > I am planning to do MD simulations for a pretty large system. The
> > system is composed of several protein molecules. I want to apply
> > periodic boundary condition in the Z direction for the system.
> > However, one of the protein will cross the boundary of the PBC box I
> > am going to use. How does the CHARMm (academic cersion) deal with this
> > kind of probelm? Can I just simply truncate the part out of the
> > primary box and put it back into the image position in the primary
> > box? Based on my experience for small molecule simulations, this needs
> > carefulness to deal with the inter and intra interactions. I am not
> > sure how CHARMm deal with it.
>
>
> =+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
> Rick Venable           29/500
> FDA/CBER/OVRR Biophysics Lab
> 1401 Rockville Pike    HFM-419
> Rockville, MD  20852-1448  U.S.A.
> (301) 496-1905   Rick_Venable-.at.-nih.gov
> ALT email:  rvenable-.at.-speakeasy.org
> -------------------------------------
> "Don't blame me, I voted for Kang."
>                          Homer
> =+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
>

---

From: Rick Venable <rvenable^at^pollux.cber.nih.gov>
Date: Wed, 23 Jun 2004 13:22:00 -0400

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable           29/500
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905   Rick_Venable^at^nih.gov
ALT email:  rvenable^at^speakeasy.org
-------------------------------------
"Don't blame me, I voted for Kang."
                         Homer
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=