Subject: Fwd: CCL:Why program in Java?

From: arashid.-at-.iqe.phys.ethz.ch
Date: Thu, 24 Jun 2004 23:06:17 +0000

Forwarded Message:
> To: "Mark Thompson" <mark.-at-.arguslab.com>
> From: Egon Willighagen <egonw.-at-.sci.kun.nl>
> Subject: CCL:Why program in Java?
> Date: Sat, 5 Jun 2004 16:27:13 +0200
> -----
<pre>
On Friday 04 June 2004 18:00, Mark Thompson wrote:
> One major drawback to scientific programing in Java, at the present time,
> is good 3D graphics. 

I agree with the situation that OpenGL support for Java is not where it should 
be... Java3D had very many bugs, and I guess JOGL is its successor announced 
quite some time ago already, and have not heard much about it yet...

But, the good news is, that for top quality molecular graphics, you don't 
necessarily need hardware accelerated graphics... Unless you need a *very* 
general 3D library, but just focus on molecular stuff, I would suggest to 
have a look at the Jmol v10 prereleases of which demo's can be found on this 
website:

<a 
href="http://jmol.sourceforge.net/preview/">http://jmol.sourceforge.net/preview/
</a>

Note that thousands of atoms as in the Nanotech example are not really a 
problem. In the field of biomolecular sciences, there are nice examples of 3D 
rendering in cartoon, ribbon format and some others.

Not likely the best performance ever, but very close.

Egon

-= This is automatically added to each message by the mailing script =-
To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
and send your message to:  CHEMISTRY.-at-.ccl.net

Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST.-at-.ccl.net 
HOME Page: <a href="http://www.ccl.net">http://www.ccl.net</a>  | Jobs Page: <a 
href="http://www.ccl.net/jobs">http://www.ccl.net/jobs</a>

If your mail is bouncing from CCL.NET domain send it to the maintainer:
Jan Labanowski,  jlabanow.-at-.nd.edu (read about it on CCL Home Page)
-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

</pre>

---

From: arashid(at)iqe.phys.ethz.ch
Date: Thu, 24 Jun 2004 06:11:27 +0000

Forwarded Message:
> To: jle(at)theworld.com
> From: Boris Gorelik <bgbg(at)pob.huji.ac.il>
> Date: Thu, 17 Jun 2004 17:31:52 +0300
> -----
<pre>
There is an interesting benchmark that compares Java productivity (Sun Java 
1.4.2_01) vs C++ (gcc3.3.1).
The author claims that in most tasks Java performance was superior.
The full story is here:

<a href="http://www.sys-con.com/story/?storyid=45250">http://www.sys-
con.com/story/?storyid=45250</a>

On Friday 04 June 2004 14:46, jle(at)TheWorld.com wrote:
> Folks, I would appreciate pointers to any article/book discussing
> the pros and cons of programming in Java.  Either with regards to
> other interpreted languages such as Python/Perl, or with regards
> to compiled languages such as C/C++.  Truly comparative articles
> would be best, although evangelical texts would suffice (i.e. I've
> read some of the XP literature :-).
>
> Thanks in advance!
>
> Joe
>
>
> To send e-mail to subscribers of CCL put the string CCL: on your Subject:
>
> Send your subscription/unsubscription requests to:
> CHEMISTRY-REQUEST(at)ccl.net HOME Page: <a 
href="http://www.ccl.net">http://www.ccl.net</a>  | Jobs Page:
> <a href="http://www.ccl.net/jobs">http://www.ccl.net/jobs</a>
>

-- 
Boris Gorelik
-= ( 2*b || !(2*b)) That's the question =-
Thu, 17/Jun/2004, 28 Sivan 5764
-------------------------------------------------
! Molecular Modelling Group !
! Pharmacy School, Hadassa Faculty of medicine !
! The Hebrew University of Jerusalem !
! http: // www .md.huji.ac.il/models/group.html !
!
!------------------------------------------------

-= This is automatically added to each message by the mailing script =-
To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
and send your message to:  CHEMISTRY(at)ccl.net

Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST(at)ccl.net 
HOME Page: <a href="http://www.ccl.net">http://www.ccl.net</a>  | Jobs Page: <a 
href="http://www.ccl.net/jobs">http://www.ccl.net/jobs</a>

If your mail is bouncing from CCL.NET domain send it to the maintainer:
Jan Labanowski,  jlabanow(at)nd.edu (read about it on CCL Home Page)
-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

</pre>