Subject: Re: CCL:Orient molecule

From: "Tamas E. Gunda" <tgunda^at^puma.unideb.hu>
Date: Thu, 24 Jun 2004 10:10:13 +0200

Steve,

Mol2mol has an advanced rotation toolbar, which has the options you are looking for. In
addition, you can decide wheter to apply or not the screen rotations to the original
coordinates and to save them.
Look at:
http://web.interware.hu/frenzy/mol2mol

or the rotation stuff:

http://web.interware.hu/frenzy/mol2mol/m2m/graphwin.htm#rot_summary

Regards

Tamas Gunda
University of Debrecen, Hungary
tgunda *at* puma.unideb.hu

----- Original Message ----- 
From: "Steve Bowlus" <chezbowlus^at^goldrush.com>
To: <chemistry^at^ccl.net>
Sent: Thursday, June 24, 2004 5:42 AM
Subject: CCL:Orient molecule

> I am frantically searching for a simple piece of code that will allow me to:
>
> Read a standard file (mol, pdb, Sybyl ...)
> select an atom to put at the Cartesian origin
> select an atom to put on the X axis
> select an atom to put in the XY plane
> Do a rigid rotation
> Do sequential rigid rotations about Cartesian axes
> Freeze the molecule in the new orientation
> Output the NEW, transformed coordinates.
>
> This is equivalent to the Sybyl "orient" command, plus rigid rotations, plus
> "Freeze molecule". But I have not found a free (or even cheap) package that
> will freeze a molecule in the new coordinates before output.
>
> Thanks in advance for any pointers,
> Steve
>
>
> -= This is automatically added to each message by the mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
> and send your message to:  CHEMISTRY^at^ccl.net
>
> Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST^at^ccl.net
> HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs
>
> If your mail is bouncing from CCL.NET domain send it to the maintainer:
> Jan Labanowski,  jlabanow^at^nd.edu (read about it on CCL Home Page)
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>
>
>
>
>

---

From: "M. L. Dodson" <bdodson|at|scms.utmb.EDU>
Date: Thu, 24 Jun 2004 07:10:51 -0500

On Wednesday 23 June 2004 10:42 pm, Steve Bowlus wrote:
> This is equivalent to the Sybyl "orient" command, plus rigid rotations,
> plus "Freeze molecule". But I have not found a free (or even cheap)
> package that will freeze a molecule in the new coordinates before output.
>

I do not know of a mouse and windows package that will do what you
want, but it is easy with a 6-8 line nab program:
http://www.scripps.edu/case/

As I have posted here in the past, nab is a "molecular
manipulation" language with a syntax similar to C, but with atoms,
molecules, etc as primitive data types.  I use it extensively to
create the starting structures of quite complex molecules for
computational chemistry.  E.g., creating a B-DNA molecule of
arbitrary sequence is a 4-5 line program.

Licensed under the GPL, very well documented, runs on any 32-bit
Unix (e.g., Linux and BSD), and costs no money.  But you will need
to do some programming.

Good luck.
-- 
M. L. Dodson                                bdodson|at|scms.utmb.edu
409-772-2178                                FAX: 409-772-1790