Subject: RE: Orient molecule

From: "Mark Thompson" <mark=at=arguslab.com>
Date: Thu, 24 Jun 2004 12:44:57 -0700

ArgusLab 4.0 can do this.

http://www.arguslab.com

Mark

***************************
Mark Thompson
ArgusLab
PO Box 55207
Seattle, WA  98155
FAX: 206.440.3305

mark=at=arguslab.com
http://www.arguslab.com
***************************

-----Original Message-----
From: Computational Chemistry List [mailto:chemistry-request=at=ccl.net]On
Behalf Of Steve Bowlus
Sent: Wednesday, June 23, 2004 8:42 PM
To: chemistry=at=ccl.net
Subject: CCL:Orient molecule

I am frantically searching for a simple piece of code that will allow me to:

Read a standard file (mol, pdb, Sybyl ...)
select an atom to put at the Cartesian origin
select an atom to put on the X axis
select an atom to put in the XY plane
Do a rigid rotation
Do sequential rigid rotations about Cartesian axes
Freeze the molecule in the new orientation
Output the NEW, transformed coordinates.

This is equivalent to the Sybyl "orient" command, plus rigid rotations, plus
"Freeze molecule". But I have not found a free (or even cheap) package that
will freeze a molecule in the new coordinates before output.

Thanks in advance for any pointers,
Steve

-= This is automatically added to each message by the mailing script =-
To send e-mail to subscribers of CCL put the string CCL: on your Subject:
line
and send your message to:  CHEMISTRY=at=ccl.net

Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST(at)ccl.net
HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs

If your mail is bouncing from CCL.NET domain send it to the maintainer:
Jan Labanowski,  jlabanow(at)nd.edu (read about it on CCL Home Page)
-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

---

From: "Warren DeLano" <warren[at]delanoscientific.com>
Date: Wed, 23 Jun 2004 22:59:43 -0700

Steve,

This is something PyMOL can do with a little help from Python...
  
# PyMOL script: view2coord.pml

# get the current camera matrix
v=cmd.get_view()

# translate atoms to the current origin of rotation
alter_state 1, all, \
(x,y,z) = (x-v[12],y-v[13],z-v[14])

# apply the rotation (matrix multiplication)
alter_state 1, all, \
(x,y,z) = (x*v[0]+y*v[3]+z*v[6], \
x*v[1]+y*v[4]+z*v[7], x*v[2]+y*v[5]+z*v[8])

# end script

After loading a molecule and choosing a view (either with the mouse, or
using commands like "orient", "turn", "move", "center", etc.), you then
simply run the script and save the new coordinates:

load original_mol.pdb
orient
center 10/ca
@view2coord.pml
save transformed_mol.pdb
quit

Oh, and yes, PyMOL is still free unless you choose to pay for it.

Cheers,
Warren

--
mailto:warren[at]delsci.com
Warren L. DeLano, Ph.D.
Principal Scientist
DeLano Scientific LLC
Voice (650)-346-1154 
Fax   (650)-593-4020

> From: Computational Chemistry List 
> [mailto:chemistry-request[at]ccl.net] On Behalf Of Steve Bowlus
> To: chemistry[at]ccl.net
> Read a standard file (mol, pdb, Sybyl ...) select an atom to 
> put at the Cartesian origin select an atom to put on the X 
> axis select an atom to put in the XY plane Do a rigid 
> rotation Do sequential rigid rotations about Cartesian axes 
> Freeze the molecule in the new orientation Output the NEW, 
> transformed coordinates.
> 
> This is equivalent to the Sybyl "orient" command, plus rigid 
> rotations, plus "Freeze molecule". But I have not found a 
> free (or even cheap) package that will freeze a molecule in 
> the new coordinates before output.
> 
> -= This is automatically added to each message by the mailing 
> script =- To send e-mail to subscribers of CCL put the string 
> CCL: on your Subject: line and send your message to:  
> CHEMISTRY[at]ccl.net
> 
> Send your subscription/unsubscription requests to: 
> CHEMISTRY-REQUEST[at]ccl.net 
> Jan Labanowski,  jlabanow[at]nd.edu (read about it on CCL Home Page)