Subject: Re: CCL:About Scratch usage in Gaussian

From: "Pablo Vitoria" <qibvigap/at/lg.ehu.es>
Date: Thu, 28 Oct 2004 10:00:09 +0200

Hi Rachel,

As 335803017 words is 2.5 GB, you are hitting the 2GB file limit which was
usual in Windows or Linux systems. You have two options.If  you have access
to the source code, you can recompile it with large file support (it can be
done with g03 in Linux, I don4t know about g98 or other OS). If you don4t,
you can split the .rwf in several parts using Link0 commands that must be at
the beginning of your input file. For example, if you use /scratch as your
scratch directory, you can split your .rwf file in two parts of less tan 2GB
each including:

%rwf=/scratch/1.rwf,245MW,/scratch/2.rwf,245MW

I copy below from the g03 manual:

%RWF=loc1,size1,loc2,size2, ...
An alternate syntax is provided for splitting the Read-Write file among two
or more disks (or file systems). Each location is followed by a maximum size
for the file segment at that location. The default units for each size is
words; the value may be optionally followed by KB, MB, GB, KW, MW or GW
(with no intervening spaces) to indicate units. A value of -1 for any size
parameter indicates that any and all available space may be used, and a
value of 0 indicates that an existing segment should retain its current
size. The locations may be either directory locations, or full pathnames.
Note that directory specifications must include terminal slashes (on UNIX
systems).

Pablo

--------------------------------------------------------
Pablo Vitoria Garcia
Dpto. Qummica Inorganica, Facultad de Ciencias
Universidad del Pams Vasco (UPV/EHU)
Aptdo. 644
48080 Bilbao (Bizkaia)

Tfno. 94 6015992
Fax. 94 6013500
----- Original Message ----- 
From: "raquel crespin" <rache97/at/yahoo.com>
To: <chemistry/at/ccl.net>
Sent: Wednesday, October 27, 2004 4:57 PM
Subject: CCL:About Scratch usage in Gaussian

| Hello CCL members!
| I tried to run MP2/aug-cc-pVTZ calculation with g98,
| my system have 7 atoms (230 basis functions and 333
| primitives) and after few minutes the following
| message appears:
| Estimated scratch disk usage=   336257611 words.
|  Actual    scratch disk usage=   335803017 words.
|  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
|  Actual    scratch disk usage=   335802069 words.
| Erroneous write during file extend. write 61632511
| instead of 4096
| Probably out of disk space.
|  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
|  Actual    scratch disk usage=   335802069 words.
| Erroneous write during file extend. write 61632511
| instead of 4096
| Probably out of disk space.
|  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
|  Actual    scratch disk usage=   335802069 words.
| Erroneous write during file extend. write 61632511
| instead of 4096
| Probably out of disk space.
|  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
|  Actual    scratch disk usage=   335802069 words.
| Erroneous write during file extend. write 61632511
| instead of 4096
| Probably out of disk space.
|  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
|  Actual    scratch disk usage=   335802069 words.
| Erroneous write during file extend. write 61632511
| instead of 4096
| Probably out of disk space.
| and the calculation stops. I change %mem, %Maxdisk and
| test with direct procedure, but the problem continues.
| What can I do in this case?
| Thanks
| Rachel
|
|
|
| __________________________________
| Do you Yahoo!?
| Take Yahoo! Mail with you! Get it on your mobile phone.
| http://mobile.yahoo.com/maildemo
|
|
| -= This is automatically added to each message by the mailing script =-
| To send e-mail to subscribers of CCL put the string CCL: on your Subject:
line
| and send your message to:  CHEMISTRY/at/ccl.net
|
| Send your subscription/unsubscription requests to:
CHEMISTRY-REQUEST/at/ccl.net
| HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs
|
| If your mail is bouncing from CCL.NET domain send it to the maintainer:
| Jan Labanowski,  jlabanow/at/nd.edu (read about it on CCL Home Page)
| -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|
|
|
|
|
|

---

From: Georgina Aitken <g.d.c.aitken..at..sussex.ac.uk>
Date: Thu, 28 Oct 2004 11:45:53 +0100

Dear Raquel,

you could try splitting up the rwf files that are generated during the 
calculation as these usually use the most memory.
On the first line of your input file give the directory where the .rwf 
files are generated (e.g. work) followed by a the file names for each rwf 
file (e.g scratch1):

%RWF=/work/scratch1,1900MB,/work/scratch2,1900MB,/work/scratch3,1900MB,/wor
k/scratch4,1900MB
%NoSave
%chk=etc.chk
....

You can generate as many rwf files as necessary.
So that these files are automatically deleted once the calc has finished I 
put %Nosave command on the second line of my input file followed by the 
rest of the input for the calculation.

Georgina Aitken

--On Wednesday, October 27, 2004 07:57:14 -0700 raquel crespin 
<rache97..at..yahoo.com> wrote:

> Hello CCL members!
> I tried to run MP2/aug-cc-pVTZ calculation with g98,
> my system have 7 atoms (230 basis functions and 333
> primitives) and after few minutes the following
> message appears:
> Estimated scratch disk usage=   336257611 words.
>  Actual    scratch disk usage=   335803017 words.
>  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
>  Actual    scratch disk usage=   335802069 words.
> Erroneous write during file extend. write 61632511
> instead of 4096
> Probably out of disk space.
>  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
>  Actual    scratch disk usage=   335802069 words.
> Erroneous write during file extend. write 61632511
> instead of 4096
> Probably out of disk space.
>  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
>  Actual    scratch disk usage=   335802069 words.
> Erroneous write during file extend. write 61632511
> instead of 4096
> Probably out of disk space.
>  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
>  Actual    scratch disk usage=   335802069 words.
> Erroneous write during file extend. write 61632511
> instead of 4096
> Probably out of disk space.
>  IMap=  1  2  3  4 13  5 12  6 11  7 10  8  9
>  Actual    scratch disk usage=   335802069 words.
> Erroneous write during file extend. write 61632511
> instead of 4096
> Probably out of disk space.
> and the calculation stops. I change %mem, %Maxdisk and
> test with direct procedure, but the problem continues.
> What can I do in this case?
> Thanks
> Rachel
>
>
> 		
> __________________________________
> Do you Yahoo!?
> Take Yahoo! Mail with you! Get it on your mobile phone.
> http://mobile.yahoo.com/maildemo
>
>
> -= This is automatically added to each message by the mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject:
> line and send your message to:  CHEMISTRY..at..ccl.net
>
> Send your subscription/unsubscription requests to:
> CHEMISTRY-REQUEST..at..ccl.net  HOME Page: http://www.ccl.net   | Jobs Page:
> http://www.ccl.net/jobs
>
> If your mail is bouncing from CCL.NET domain send it to the maintainer:
> Jan Labanowski,  jlabanow..at..nd.edu (read about it on CCL Home Page)
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>
>
>
>