Subject: Re: CCL:Software for pattern recognition in QSAR studies?

From: "Joerg K. Wegner" <wegnerj..at..informatik.uni-tuebingen.de>
Date: Thu, 02 Dec 2004 08:51:08 +0100

Hi all,

>>I am looking for a program that can apply standard pattern recognition
>>techniques. Basically, I want to study a number of samples, each of
>>which can be characterized by some properties. I would like to classify
>>these samples into several groups based on these properties, and then
>>derive a QSAR model for each group.
You can e.g. use JOELib for the descriptor calculation (up to >3000, 
depends on the used parameters). Most popular ones: RDF, BCUT, ...

For the data mining step there are programming interfaces to Weka and 
Matlab. If you don't want to use the interfaces you can simply export a 
text file with descriptors and use your own tools.

Kind regards, Joerg
-- 
Dipl. Chem. Joerg K. Wegner
Center of Bioinformatics Tuebingen (ZBIT)
Department of Computer Architecture
Univ. Tuebingen, Sand 1, D-72076 Tuebingen, Germany
Phone: (+49/0) 7071 29 78970
Fax: (+49/0) 7071 29 5091
E-Mail: mailto:wegnerj..at..informatik.uni-tuebingen.de
WWW:    http://www-ra.informatik.uni-tuebingen.de
--
Never mistake motion for action.
                                     (E. Hemingway)

Never mistake action for meaningful action.
                                (Hugo Kubinyi,2004)

---

From: "E.L. Willighagen" <e.willighagen{at}science.ru.nl>
Date: Thu, 2 Dec 2004 11:33:48 +0100

On Thursday 02 December 2004 09:55, you wrote:
> To: <chemistry{at}ccl.net>
> Subj: CCL: Re: Software for pattern recognition in QSAR studies?
>
> Renxiao Wang wrote:
> > ...
> When all propoerties are non-numerical (e.g. property 1 takes values
> A or B or C, property 2 takes value red or green or blue, property 3
> takes values: alpha or beta or gamma or delta, etc...), there is
> a classification method able to compute the optimal partition,
> including the number of classes: very few methods can do this.
> Freeware with reference and documentation:
> http://petitjeanmichel.free.fr/itoweb.petitjean.freeware.html#POP

Classification and Regression Trees (CART) can be do that... there are two or 
three packages (one is tree) for R available. See http://cran.r-project.org/.

Egon

- -- 
e.willighagen{at}science.ru.nl
PhD-student on Molecular Representation in Chemometrics
Radboud University Nijmegen
http://www.cac.science.ru.nl/people/egonw/
GPG: 1024D/D6336BA6