Subject: Re: CCL:W:Algorithms to cut a surface from a crystal

From: Chimica Teorica <teoricach +*+ unito.it>
Date: Wed, 13 Apr 2005 17:37:02 +0200

"Jrg-Rdiger, , Hill" wrote:
> 
> Hi,
> I am trying to write some code which takes the unit cell of a crystal (both the cell vectors and the coordinates of the atoms) and creates a "cell" for a surface of the crystal (for a given set of Miller indices). I am having a little bit of a problem getting the coordinates of the atoms in the "surface cell" right.
> I thought that this should be a standard problem, but I can't find anything about a suitable algorithm for doing this neither on the Web nor in standard crystallography text books. If anybody has any pointers either to code or text books on this subject I would appreciate it.
> 
> Best Regards,
> Jrg-Rdiger Hill
> 
> -= This is automatically added to each message by the mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
> and send your message to:  CHEMISTRY +*+ ccl.net
> 
> Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST +*+ ccl.net
> HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs
> 
> If your is mail bouncing from ccl.net domain due to spam filters, please
> use the Web based form from CCL Home Page
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

The program CRYSTAL allows cutting of a slab (periodic in 2D) parallel 
to a given crystallographic plane.

See http://www.crystal.unito.it => tutorials => Surfaces and adsorption 

CRYSTAL support team Torino

---

From: "Dr. Peter Bladon" <cbas25~at~strath.ac.uk>
Date: Wed, 13 Apr 2005 18:57:08 +0100

Perhaps Interchem-PC does what you want
See http://www.interprobe.co.uk/inter/interprobe.html

It allows the creation of nests of unit cells, and allows the operator 
to orient the display, so that the "crystal" is viewed in a  direction 
normal to the plane defined by Miller indices, or in a direction 
parallel to this plane.  With parallel viewing, it is them possible to 
"slice" the crystal parallel to the plane, using one (top) or two (top 
and bottom) slices.  This will give a wafer of controllable thickness, 
at least in the cases of ionic crystals.  Whether the process has any 
validity with the generality of molecular crystals is open to question; 
but being performed in silico there are minimal hazards due to toxic waste!!

If you go to the download site you can get an executable version of the 
program as well as the appropriate Fortran-90 code. 

Yours sincerely

Peter Bladon
------------------------------------------
Original message
Jrg-Rdiger, , Hill wrote:

> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>
>
>
>
>
>
>  
>