Subject: CHARMm .DCD distance extraction

From: [email-masked] (Kenneth Butenhof)
Date: Fri, 7 Aug 92 11:40:39 -0400

Dear CHARMm user(s),

	I have a CHARMm MD data file (.DCD) from which I would like to
extract a set of interatomic distances (for all frames).  I have used the
CORREL command for bond distance extractions, however this requires that
the atoms be bonded (or at least have a atom types compatible for bonding).
Of course, I could add new entries into the  .PRM  (.bin) file but this 
seems messy, and possibly dangerous.  Is there a way to extract distances of
unbonded sets of atoms, and generate statistics on the fluctuations?

	Unfortunately the CHARMm "package", on the CRAY at OSC, does not 
include the analysis modual - that would make it too easy.

	Yes, of course I should get Quanta -- but I don't have it now.

	-- any (other) suggestions would be greatly appreciated!

--
					Ken Butenhof
					Department of Pediatrics
					Case Western Reserve University
					Cleveland, Ohio  44106

---
Administrivia: This message is automatically appended by the mail exploder.
[email-masked] --- everybody; [email-masked] --- coordinator only
[email-masked] : send something from chemistry; FTP: www.ccl.net
---

---

From: [email-masked]
Date: 7-AUG-1992 17:11:38.61

One solution to extracting atomic distances from a CHARMm .DCD trajectory
file is provided by the following:

------------------------
Note. The following example reads a .PSF file for your system and
      calculates the distances between atoms 1:6 and 530:542.
      This is a straight forward application of the DIST command
      (page 8 of Lecture #5,  CHARMM COURSE by Bernie Brooks at
       the NIH---you'll have to contact him for your own copy of
       the notes [about 500 pages]. I'll fax you a copy of the relevant
       page if you need it).

Good luck,
Wayne Sonnen
-------------------
* Script file produced by WAYNE
* 
open write unit 7 Card name JUNK.LOG line
outu 7
bomlev -2
bann
 
OPEN READ UNIT 63 FILE NAME DNA_PSF.PSF
READ PSF UNIT 63
OPEN READ UNIT 52 FILE NAME SI1_NO.DCD

TRAJ IREAD 52 NREAD 1 EXPA NFILE 20

SET 1 1
LABEL L1
  TRAJ READ
  COOR DIST CUT 11.0 SELE BYNUM 1:6 END SELE BYNUM 530:542 END
  INCR 1 BY 1
IF 1 LT 20.5 GOTO L1

STOP

---