Subject: gaussian 92 and GEN basis sets

From: [email-masked] (Jussi Eloranta)
Date: Tue, 7 Jun 1994 10:25:55 +0300 (EET DST)

Hi,

I obtained basis set for fluorine (ftp.ccl.net: basis set library).
Now, I tried to use the following exponents and coefficients with g92
(user specified basis set):

###############################################################################
# atomic SCF calculation of --->  F(2P) 7s4p  <---
# SCF energy is      -99.3462183972 a.u. (virial theorem =  2.000000000)
# A. Schaefer, Jan. 92
###############################################################################
#     exponents         coefficients
#                         1s                2s
#    2973.4997046     -.52590584026E-02 -.12092301431E-02
#    447.25783120     -.39233645111E-01 -.93573417113E-02
#    101.57185900     -.17619356211     -.42823390798E-01
#    28.268552755     -.45719988226     -.14052491559
#    8.7349389301     -.44730688010     -.19520721834
#    1.3841118258     -.37028368038E-01  .51799309070
#    .41199921824      .89840651033E-02  .60912564518
#  eigenvalue        -26.3659766        -1.5632256
#  occupation          2.0000000         2.0000000
#                         2p
#    22.658300194      .44897518573E-01
#    4.9749914492      .23575465344
#    1.3466519487      .50828613121
#    .34729031582      .45821884951
#  eigenvalue          -.7161735
#  occupation      3 * 1.6666667
###############################################################################
*

Then I generate the following stream for g92:
# HF/GEN

Tetst run

0 2
    9

-F
S   14 1.0
    197347.11959     -.28184163023E-04  
    29558.776324     -.21907068471E-03  
    6726.9377956     -.11500051437E-02  
    1905.1637291     -.48260180222E-02  
    621.37226145     -.17221358226E-01  
    224.17852083     -.53099042237E-01  
    87.234531917     -.13789697333      
    35.916025242     -.28114096672      
    15.415563071     -.38289777654      
    6.7358200331     -.24413469399      
    2.5569609365     -.32911334952E-01 
    1.1138310004      .24115272055E-02 
    .44549974207     -.17148852940E-02 
    .16466803857      .16641631481E-03 
S   14 1.0
    197347.11959      .63622475516E-05
    29558.776324      .49409450159E-04
    6726.9377956      .26000984572E-03
    1905.1637291      .10919343116E-02
    621.37226145      .39388403025E-02
    224.17852083      .12360484265E-01
    87.234531917      .33873593861E-01
    35.916025242      .76642243943E-01
    15.415563071      .13666725679
    6.7358200331      .13332951903
    2.5569609365      -.11442436559
    1.1138310004      -.44921371698
    .44549974207      -.46114921253
    .16466803857      -.13972573436
P 11 1.0
    734.58063291      .13461172732E-03
    174.10266268      .11647895815E-02
    56.410104865      .62228913925E-02
    21.298831774      .23990521555E-01
    8.8087650181      .71566280999E-01
    3.8734203606      .16053699622
    1.7478894590      .25856388471
    .78248058089      .30564723272
    .33863051221      .27306024051
    .13832555824      .17291405016
    .51441819864E-01  .52370788368E-01
****

1s and 2s eigenvalues are correct (ie. as described in basis set library)
but the 2p ones are not. And, of course, the total energy is greater than
mentioned in the basis set library.

I tried simpler atoms (like H, Li) which only had s orbitals and those worked
ok.

Any ideas?

Regards,

Jussi Eloranta

---

From: System Admin (Mike Peterson) <[email-masked]>
Date: Tue, 7 Jun 1994 10:28:51 -0400

Your problem is that G92 defaults to UHF when it finds an open shell
calculation, and you need ROHF to reproduce the calculation.
Forcing ROHF will not work either, since it occupies the P orbitals
with 2, 2 and 1 electrons respectively, not the 5/6 per P orbital
that the F(2P) state requires. I'm not sure you can reproduce this
calculation with Gaussian even with alteration of the initial guess
since you have to force the 5/6 occupation all through the SCF as well.
This is normally done using Coulomb and Exchange coupling constants
that are specific to each state and occupation scheme (here 5 electrons
in a triple degenerate level), and I don't see anywhere that G92 lets you
put them in. I'd like to know how it can be done too.

You will get H atom right because UHF=ROHF for the 1 electron case,
but I'm surprised you get Li atom right - UHF should give 2 alpha
spin eigenvalues, and 1 beta spin eigenvalue which wouldn't match
the first alpha eigenvalue except by accident (or if the 1s AO describes
exactly the lowest MO, which it might if this basis set was energy
optimized on the atom, so that none of the 2s AO gets mixed in?).

The ROHF option will give the right answer for Li since the open shell
is singly degenerate - ROHF will get all cases right where the open
shell is exactly half occupied with alpha spin electrons (the "high
spin" cases), provided the proper initial guess orbitals are occupied.

The (obsolete) MONSTERGAUSS program will do this type of ROHF with explicit
control over the orbital occupation (and computes the correct coupling
constants for most real-life cases except some excited pi states of linear
molecules), but it can't handle contraction schemes involving more than
10 primitives.

Mike Peterson, U/Toronto Department of Chemistry
E-mail: [email-masked]