Subject: More benchmarks

From: "Mr. Berkley Shands" <[email-masked]>
Date: Mon, 17 Oct 1994 12:04:58 -0500

Receptor-III (TM - Tripos Associates) Release version V3.0 timings for the ACE
series. Uniform Radial Increments at 0.25 Angstroms. Modified Mode Adaptive Sampling.
Minimum scan factor 2.57 degrees, maximum scan factor 45.84 degrees, Average of 11.55.
Uniform grid resolution of 0.25A. Fully automated setup and processing applied.
Coordinates, torsions, and constraints calculated in double precision.

The dataset consists of 45 MOPAC/AM1 minimized molecules having an IC50 > 6.0.
All molecules pre-processed automatically for high energy conformer avoidance.
Smallest molecule had 5 variable torsions (1e07 max conformers).
Largest molecule had 19 variable torsions (1e27 max conformers).

*******************************************************************************
Benchmarks of the ACE series of 45 molecules IC50 > 6.0
*******************************************************************************

Elapsed Child_CPU System_CPU  Chargable Forks  Ratio
======= ========= ==========  ========= =====  =====

   1183   810.810     16.120    756.600     2  0.695 SGI Indigo 48Mb -O2 (R3K/33Mhz)
    383   736.120     27.810    670.770     5  1.979 SGI 4d/380s 4/8 128Mb -O2 (R3K/33Mhz)

    463   335.690      6.220    311.060     2  0.736 SGI Challenge M 96Mb -O2 (R4K/100Mhz)
    498   345.930      8.200    320.140     2  0.709 SGI Indigo2 64Mb -O2 (R4K/50Mhz)

    345   293.183      5.017    249.233     2  0.870 AXP 3K/300 Std CC -O2 32mb V3.0
    311   263.700      4.233    222.033     2  0.870 AXP 3K/300 Gem CC -O4 32Mb V3.0
    431   242.817      4.983    201.317     2  0.581 AXP 3K/400 Gem CC -O4 64Mb V2.0
    418   242.267     10.983    200.150     2  0.590 AXP 3K/300 Gem CC -O4 32Mb V2.0
    181   188.800      3.317    160.167     3  1.073 AXP 2100-5 2/4 Gem CC -O4 128Mb V2.0
    113   100.533      1.300     84.333     2  0.906 AXP 3K/900 Gem CC -O4 512Mb 275Mhz V3.0

Notes:

Street value for the above machines:

AXP 3K/900 $45K, AXP 2100-500 (4cpu) $60K ($100K Loaded)
AXP 3K/300 $4k (used) $8K (new)
AXP 3K/400 $10K
SGI Indigo $12K, Indigo2 $15K, Challenge M $20K
SGI 4d/380 ($150K new) $15K today used.
ALL machines should have at least 64Mb, with the AXP 2100-500 at 128Mb minimum.
The greatly effects the SGI price upward.
No SGI R8000 (TFP) timings are available, but at $500K, it doesn't seem
worthwhile :-)

All SGI machines ran IRIX 5.2 except the Indigo2 at 4.0.5

The "GEM" compiler is in save set DECC on the OSF/1 CD at V3.0.
          (cc -migrate; requires CMPDEVENH and OTABASE at V2.0)
The "STD" compiler is the default "CC" for OSF/1.

"Child_CPU"  is the recorded total CPU for all forked processes, including
	     overhead and I/O.
"Elapsed"    is the recorded elapsed time from command line parsing to
	     the exit of the last child processes.
"System_CPU" is the recorded UNIX system overhead from the times() function
"Chargable"  is the algorithmic chargable time from initial rotations
	     to termination (child process CPU)

*****************************************************************************
	CPU benchmarking for current architectures September 1994.
	Software is an analytic ring closure 
        Multiprocessor test suite

	"Elapsed" is the wall clock time.
        "Child_CPU" is the total CPU over all forks.
	"System_CPU" is measured system overhead.
	"Conformers" are stericly allowed conformers.
                     (of the last molecule processed)
	"Forks" is the number of fork() system calls.
        "Ratio" is Child_CPU / Elapsed
        "Ovhd/Fork" is the System_CPU / Forks.

pentcrys (cyclic pentapeptide with distance constaints)
cyclooctane - cycloalkane with hydrogens.

*** Single Threaded Application - Ringsearch ***

DEC Alpha 3000/900 (275Mhz 512Mb OSF1 V3.0) Uniprocessor
Elapsed Child_CPU System_CPU  Conformers
    455   452.650      0.533        1515

DEC alpha 2100 - 1/4 cpu (128 Mb OSF1 V3.0) Multiprocessor
Elapsed Child_CPU System_CPU  Conformers
    731   729.700      0.100        1515

wubs2 DEC Alpha AXP 3000/300 (32MB OSF1 V3.0) Uniprocessor
Elapsed Child_CPU System_CPU  Conformers
   1261  1243.317      1.967        1515

sgi 4d/380 1/8 cpus (128Mb IRIX 5.2) Multiprocessor
Elapsed Child_CPU System_CPU  Conformers
   3738  3747.350     22.680        1515

************ Multisearch (multi-threaded ringsearch) *****************

DEC Alpha 3000/900 (275Mhz 512Mb OSF1 V3.0) Uniprocessor
Elapsed Child_CPU System_CPU  Conformers Forks  Ratio Ovhd/Fork
    460   453.217      1.350        1515   353  0.985 0.003824

DEC alpha 2100 - 4/4 cpu (128 Mb OSF1 V3.0) Multiprocessor
Elapsed Child_CPU System_CPU  Conformers Forks  Ratio Ovhd/Fork
    195   753.717      1.833        1515   353  3.865 0.005194

sgi 4d/380 (128Mb IRIX 5.2) 4/8 cpus 
Elapsed Child_CPU System_CPU  Conformers Forks  Ratio Ovhd/Fork
    973  3813.390     42.180        1515   353  3.919 0.119490

sgi 4d/380 (128Mb IRIX 5.2) 8/8 cpus 
Elapsed Child_CPU System_CPU  Conformers Forks  Ratio Ovhd/Fork
    549   4012.360     54.070        1515   353  7.308 0.153173

*************** Comments **************

IRIX throughput dropped a great deal going from 4.0.5 to 5.2
From 7.9x down to 7.3x :-(

---

From: [email-masked] (Brian A. Kell)
Date: Mon, 17 Oct 94 21:25:49 EDT

> [...]
> [...]

Excuse me?  There are R8000 machines available for substantially less
than $500K.  An R8000-based Power Indigo2 is not too much more than an
R4400-based Indigo2.

brian

------------------------------------------------------------------
Brian Kell                                          [email-masked]
Scientific Support Manager, Eastern Region     Tel. (518) 482-1436
Biosym Technologies, Inc.                      Fax. (518) 482-5433
------------------------------------------------------------------