Subject: Parallelized MD

From: [email-masked] (Noy)
Date: Fri, 18 Nov 1994 16:06:39 +0100 (NFT)

Dear cyber-chemists,
	There are so so so many tools for parallel programing freely
available on the net, PVM3, TCGMSG, P4, CHARM, HPF and so on ...... 
What is suitable specially for parallelizing existing MD code ?
What is your suggestion if one wants to work on a cluster of 
heterogenous computer environment.
							sincerely,

----------------------------------------------------------------------------
Teerakiat Kerdcharoen (NOY)

Institute of General and Inorganic and Theoretical Chemistry
Innrain 52a, A-6020 Innsbruck AUSTRIA
e-mail:  [email-masked], [email-masked], [email-masked] 
      :  [email-masked], [email-masked] ( Bangkok )
----------------------------------------------------------------------------
***  I have no past and no future. I just have today.

---

From: [email-masked] (Hinsen Konrad)
Date: Fri, 18 Nov 94 14:38:12 -0500

My experience is limited to PVM, which implements general
message-passing for a large variety of hardware setups.
Within the limits of the message-passing paradigm, I see no
important limitations imposed by PVM. However, doing parallel
calculations on a workstation cluster with PVM will
quickly demonstrate the limits of the hardware; communication
via Ethernet is slow (which of course is not PVM's fault).
For programs with medium to large communication requirements,
parallelization on a cluster will give hardly any speedup.

Anyway, most of the work necessary for parallelizing existing
code will go into the modification of the algorithms involved,
not into interfacing to a toolkit. Before you spend too
much time modifying code, have a look at the DL_POLY program,
which was recently developed at Daresbury (UK) specifically
for parallel machines, including workstation clusters.
You will find more information on it at CCP5's WWW server:
http://www.dl.ac.uk/CCP/CCP5/main.html

-------------------------------------------------------------------------------
Konrad Hinsen                     | E-Mail: [email-masked]
Departement de Chimie             | Tel.: +1-514-343-6111 ext. 3953
Universite de Montreal            | Fax:  +1-514-343-7586
C.P. 6128, succ. A                | Deutsch/Esperanto/English/Nederlands/
Montreal (QC) H3C 3J7             | Francais (phase experimentale)
-------------------------------------------------------------------------------