Subject: Re: CCL:The Pentium Bug

From: [email-masked] (David C. Doherty)
Date: Wed, 30 Nov 1994 11:03:10 -0500

At 10:00 AM 11/30/94 -0500, Subhas Chakravorty wrote:
>[...]
>Being unaware of a bug in a a product is okay but
>to defend a bug seems a bit ridiculous, at least to me.

The above statement is true.  Let me point out, however, that
what these people have actually done is to put the bug into perspective.
I'd be hard pressed to imagine that they have attempted to "defend"
it.

approximations, parameterization, coding errors, precision errors,
compiler bugs...
You seem to evince absolute faith that we have conquered all of
these ;-).

Back to work on my bug-free Motorola processor...

---
David C. Doherty
Minnesota Supercomputer Center, Inc.
[email-masked]

---

From: [email-masked] (Hinsen Konrad)
Date: Wed, 30 Nov 94 13:33:46 -0500

David C. Doherty wrote:

Not at all, but the Pentium bug is of a different quality.
All the problems you have mentioned are common; any serious
scientist doing numerical work is aware of them. On the
other hand, floating point arithmetic is something
that on the vast majority of systems works correctly.
I doubt that anyone exploring the cause of a dubious
result would start to check the FPU - I certainly wouldn't.
And the problems you have listed above keep us sufficiently
busy that we don't need to add another one, especially not
one that is so easy to avoid (simply don't use a defective
Pentium for numerical work).

And I would like to see a similar attitude towards software
development. The quality of many scientific programs, including
widely used systems, is alarmingly low. A course in software
engineering should be obligatory for all computational
scientists. And if we throw in a course in user interface
design, we might finally get rid of those programs that
waste everyone's time with silly idiosyncrasies. It's about
time that scientists realize that human time is more valuable
than CPU time.

-------------------------------------------------------------------------------
Konrad Hinsen                     | E-Mail: [email-masked]
Departement de Chimie             | Tel.: +1-514-343-6111 ext. 3953
Universite de Montreal            | Fax:  +1-514-343-7586
C.P. 6128, succ. A                | Deutsch/Esperanto/English/Nederlands/
Montreal (QC) H3C 3J7             | Francais (phase experimentale)
-------------------------------------------------------------------------------