Subject: Re: CCL:Free Fortran77??

From: Fernando Vila <[email-masked]>
Date: Fri, 5 May 1995 10:04:21 -0300 (TZ )

Estimado Antonio,
                 estoy interesado en las respuestas que recibas. Si te es 
posible, enviame un sumario.
Gracias de antemano,
                      Fernando.

*******************************************************************************
Fernando Vila       
Catedra de Quimica Cuantica          Tel.     +(5982)941860
Facultad de Quimica                  Fax      +(5982)941906
Gral.Flores 2124, C. C. 1157         E-mail   [email-masked]
Montevideo 11800, URUGUAY            WWW      http://bilbo.edu.uy/MTC-Lab.html
*******************************************************************************

---

From: Andreas Goeller <[email-masked]>
Date: Fri, 5 May 95 15:05:14 METDST

There is a GNU fortran compiler g77. It is avaiable on various
ftp sites all over the world.

---------------------------------------------------------------
   Andreas Goeller               Computer Chemie Centrum der
   Dipl.-Chem.    	        Universitaet Erlangen/Nuernberg
                                      Naegelsbachstr. 25
phone: +49(0)9131-856583               D-91052 Erlangen 
  fax: +49(0)9131-856565                   Germany
email: [email-masked]      
---------------------------------------------------------------

---

From: "Michael D. Bartberger" <[email-masked]>
Date: Fri, 5 May 1995 08:27:21 -0400 (EDT)

On Fri, 5 May 1995, Antonio Fernandez Ramos wrote:

> Dear netters:
> 
> 	Is available a free Fortran77 or 90 for MS-DOS?
> 	
> 	Thanks 
> 
> 	Antonio Fernandez-Ramos
> 	E-mail : [email-masked]
>  

Hello Antonio:

I would very much appreciate hearing about any responses you receive.
Thank you!

Regards,

Michael

________________________________________________________________________________

 Michael D. Bartberger         [email-masked]        TEL: (904) 392-3580
 Department of Chemistry       [email-masked]         FAX: (904) 846-0296
 University of Florida
 Gainesville, FL  32611
 USA
________________________________________________________________________________

Not free, but good and not expensive are Microsoft and Lahey Fortran   
compilers.

Joe McDaniel

 ----------
From:  chemistry-request[SMTP:[email-masked]]
Sent:  Friday, May 05, 1995 12:37 PM
To:  chemistry
Subject:  CCL:Free Fortran77??

Dear netters:

        Is available a free Fortran77 or 90 for MS-DOS?

        Thanks

        Antonio Fernandez-Ramos
        E-mail : [email-masked]

 -------This is added Automatically by the Software--------
 -- Original Sender Envelope Address: [email-masked]
 -- Original Sender From: Address: [email-masked]
[email-masked] -- everyone     | [email-masked] --   
coordinator
[email-masked]: HELP CHEMISTRY  | Gopher: www.ccl.net 73
Anon. ftp www.ccl.net     | [email-masked] -- archive   
search
http://www.ccl.net/chemistry.html |     for info send: HELP SEARCH to   
MAILSERV

>>>>> "Antonio" == Antonio Fernandez Ramos <[email-masked]> writes:

    Antonio> Dear netters: Is available a free Fortran77 or 90 for
    Antonio> MS-DOS?

The only free fortran compiler I am aware of is by the GNU people.  It
has recently been released in beta form and is available from
ftp://prep.ai.mit.edu/pub/gnu.  I do not know whether or not it is
portable to MS-DOS.

Hope this helps!
-Harry

+-----------------------+--------------------------------------------+
|Harry C. Johnson       |  /--- ----\  /---/ ---\ ----- /---/ /|   / |
|Computational Chemist  |  \    /   / /   / /   /  /   /   / / |  /  |
|Wavefunction Inc.      |   \  /---/ /---/ /---/  /   /---/ /  | /   |
|E-mail: [email-masked]|---/ /     /   / /   \  /   /   / /   |/    |
+-----------------------+--------------------------------------------+

From [email-masked] May 11 09:44:19 1995
Date: Tue, 9 May 1995 12:19:34 +0200 (MET DST)
From: Cezary Czaplewski <[email-masked]>
To: Antonio Fernandez Ramos <[email-masked]>
Subject: Re: CCL:Free Fortran77??

> 
> Dear netters:
> 
> 	Is available a free Fortran77 or 90 for MS-DOS?
> 	
> 	Thanks 
> 
> 	Antonio Fernandez-Ramos
> 	E-mail : [email-masked]
>  
> 
> -------This is added Automatically by the Software--------
> -- Original Sender Envelope Address: [email-masked]
> -- Original Sender From: Address: [email-masked]
> [email-masked] -- everyone     | [email-masked] -- coordinator
> [email-masked]: HELP CHEMISTRY  | Gopher: www.ccl.net 73
> Anon. ftp www.ccl.net     | [email-masked] -- archive search
> http://www.ccl.net/chemistry.html |     for info send: HELP SEARCH to MAILSERV
> 
> 

I do not know about free native fortran77 for MS-DOS but there is available
free f2c (fortran to C) converter and a great free C compiler for MS-DOS:
djgpp.

djgpp is a complete 32-bit C and C++ development environment for DOS. 
This product is intended for users who have experience using Unix, not
DOS users who expect djgpp to act like any other DOS compiler.  This is
NOT the software you want if you want to learn programming. 

Supported: 80386, 80387, 80486, XMS, himem.sys, VCPI, QEMM, 386MAX,
DesqView, Windows, OS/2.

Unsupported: XTs, 80286, multitasking, signals.

Features: 80387 emulator, 32-bit unix-ish environment, flat memory
model, debugger, SVGA graphics.

Only slight or no changes of standard f77 code are needed (for instance common
must be after all declaration). I use djgpp to compile C programs from Unix
in DOS and f2c to compile f77 code in Linux which has no f77 compiler
because I have NDP fortran for DOS but I think f2c should work good in DOS.
Djgpp is a gcc implementation for DOS and and is integrated with f2c.

And some adresses :
DJ Delorie
USmail: 24 Kirsten Ave, Rochester, NH 03867-2954, USA
email:  [email-masked]

mailing list: [email-masked] ([email-masked])
     [email-masked] ([email-masked])

File location:

    host:      omnigate.clarkson.edu
    login:     ftp
    password:  send your e-mail address
    directory: ~ftp/pub/msdos/djgpp

Many thanks to the sysops at Clarkson for providing a home to djgpp!

As a convenience to non-FTP users, djgpp is also stored on Clarkson's
archive server.  To access the archive server, do this:

   % mail [email-masked]
   Subject: <none>
   help
   index msdos/djgpp
   ^D

but there ara many other FTP sites with djgpp.

				czarek