Subject: Rasmol 2.5 and Tk 4.0

From: "Bruce W. Church" <[email-masked]>
Date: Wed, 19 Jul 1995 09:34:29 -0400 (EDT)

Hi
        Has anyone managed to get interproccess communication using 
Tk4.0 to work with RasMol 2.5.1 via the send command?  Send works 
fine with Tk3.6 but RasMol does not even show up as a registered interpreter
when Tk4.0 is running. 

I'm not on the list so please respond to my email address. 

Thanks in advance,

        Bruce Church
        [email-masked]

---

From: "Ernest Friedman-Hill" <[email-masked]>
Date: Wed, 19 Jul 1995 10:40:56 -0700

On Jul 19,  9:34am, Bruce W. Church wrote:
>-- End of excerpt from Bruce W. Church

Wow, nasty. I was just looking at the source. Rasmol does not use libtk, it
uses a home-made way of interfacing with Tk's "send" command. I imagine that
rasmol doesn't work with Tk4.0 because how send works has changed in some
subtle way.  Someone might be able to enlighten us. Software engineering has
its place!

-- 

---------------------------------------------------------
Ernest Friedman-Hill
Senior Member of Technical Staff
Scientific Computing Department
Sandia National Laboratories
Org. 8117, MS 9214
PO Box 969 Livermore, CA 94550