Subject: Re: CCL:MD/MM combination

From: Konrad Hinsen <[email-masked]>
Date: Thu, 7 Nov 96 11:07:09 +0100

> What I was trying to point out (perhaps in a very roundabout way) is that
> defining 'temperature' in this way for an MD situation is a problem (and it
> seems like all MD simply uses ideal gas results). This 'temperature' is not
> simply related to the real physical temperature.

I still don't see the problem, much less where "ideal gas" results are
used. Of course defining temperature via the equipartition theorem is
something else than using the proper definition, and it makes sense
only under certain assumptions (equilibrium, sufficiently large
system, etc.)  that are perhaps not fulfilled and that many users are
not aware of. But then that is true for many other subtle problems
related to MD. For example, conventional wisdom says that the time
step is small enough if the energy is reasonably well conserved, even
if high frequencies are not sufficiently sampled and other conserved
quantities (momentum, angular momentum) show a constant drift.

I do agree, of course, that such topics should be discussed and
analyzed, and that users of MD should be aware of the huge range
of assumptions they are implicitly making.

-- 
-------------------------------------------------------------------------------
Konrad Hinsen                          | E-Mail: [email-masked]
Laboratoire de Dynamique Moleculaire   | Tel.: +33-76.88.99.28
Institut de Biologie Structurale       | Fax:  +33-76.88.54.94
41, av. des Martyrs                    | Deutsch/Esperanto/English/
38027 Grenoble Cedex 1, France         | Nederlands/Francais
-------------------------------------------------------------------------------

---

From: Ryszard Czerminski <[email-masked]>
Date: Thu, 7 Nov 1996 12:58:08 -0500 (EST)

Few formulas from text book
(D. A. McQuarrie "Statistical Thermodynamics") :

In microcanonical ensemble ( H(p,q) = E = const)
partition function is defined as the volume of
phase space accessible at constant energy E

$$
   \Omega(E) = \int\limits_{H(p,q)=E} dp dq
$$

and thermodynamical temperature is defined by

$$
    {1 \over kT} = {\Bigl( {{\partial \Omega(E)} \over
                   {\partial E}} \Bigr)}_{N,V}
$$

(which is just different way of writing 1/T= dS/dE, since
S = k ln $\Omega$) so in order to calculate it, it is
necessary to be able to calculate partition function $\Omega(E)$
which is formidable challenge for any system a little
bit more complicated then ideal gases
and harmonic oscillators (not to mention big protein in water with
ions, etc...).

Interesting question remains how much proper thermodynamic
temperature differs from "temperature" calculated from an average kinetic
energy using equipartition theorem with all its limitations discussed so far.

 ..................................
Ryszard Czerminski
Molecular Simulations Incorporated
8 New England Executive Park
Burlington, MA 01803-5297
tel: (617)229-8875 x 217 or 229-9800
fax: (617)229-9899
e-mail: [email-masked]